Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • alexbridgez
    Participant
    Post count: 6

    Hi,
    I’m using the latest RetroPie SD card image and have run into problems in setting up the controller for use with emulationstation. It recognizes my Dualshock 3 controller but when I go to map the individual buttons things start to go wrong. When holding down a button to skip P2, it automatically maps ‘up’. When I go to map ‘down’ it does ‘down’ and ‘left’, when I map ‘right’ it does ‘right’ and ‘accept’ etc. I’ve tried with both of my Dualshock 3 controllers. Could someone guide a Pi illiterate through what it probably some rookie error on my part? Thanks :)

    alexbridgez
    Participant
    Post count: 6

    UPDATE:
    I have found why multiple presses are being registered. (Credit:David Whiddon on LifeHacker)

    “the ps3 controller draws 300amps, but the usb from the pi can only supply 100amps, thats why you’re getting the errors when pressing the buttons. I had the same problem. if you can get different controllers or a powered usb hub, then you’re golden”

    I’ve ordered a RetroZone USB Snes Controller which should do the trick :)

    petrockblog
    Keymaster
    Post count: 1828

    glad to hear!

    linhartr22
    Participant
    Post count: 1

    I’ve been having similar problems with my PS3 Dualshock 3 controller via USB. I just tried a powered USB hub with no improvement during controller setup. The hub power supply is rated at 2 amps so it should be plenty to handle the controller.

    phipix01
    Participant
    Post count: 27

    i’m having the same issues. is ther no way to achieve the correct controller setup without having to buy a powered usb hub?
    can’t we just manually assign the right buttons in es_input.cfg? or use someone elses config?
    I ordered 2x ps1/2 controller -> 1x usb adapter. anyone made any experiences with theese?

    Robert
    Guest
    Post count: 908

    same problem. I think it’s often counting releasing the button as a seperate keypress somehow. I got it mostly functional by holding down each button after i pressed it, ending with every button held down. it was a pain. Try the following in retroarch.cfg, it’s what I ended up with and it works. think L3 or R3 looks wrong; not many games use them so I haven’t tested:

    input_player1_joypad_index = 0
    input_player1_b_btn = 14
    input_player1_y_btn = 15
    input_player1_select_btn = 0
    input_player1_start_btn = 3
    input_player1_up_btn = 4
    input_player1_down_btn = 6
    input_player1_left_btn = 7
    input_player1_right_btn = 5
    input_player1_a_btn = 13
    input_player1_x_btn = 12
    input_player1_l_btn = 10
    input_player1_r_btn = 11
    input_player1_l2_btn = 8
    input_player1_r2_btn = 9
    input_player1_l3_axis = +13
    input_player1_r3_btn = 2
    input_player1_l_x_plus_axis = +0
    input_player1_l_x_minus_axis = -0
    input_player1_l_y_plus_axis = +1
    input_player1_l_y_minus_axis = -1
    input_player1_r_x_plus_axis = +2
    input_player1_r_x_minus_axis = -2
    input_player1_r_y_plus_axis = +3
    input_player1_r_y_minus_axis = -3

    Robert
    Guest
    Post count: 908

    oop http://mypiandi.blogspot.com/2012/12/retropie-sixaxis-over-bluetooth.html says L3 is button 1, otherwise it seems to agree with me.

    https://www.youtube.com/watch?v=j_Jk8up_Aqw shows automated ds3 config built into retropie(just need to know where to look), he did mention something about powered usb being better for bluetooth. The controllers themselves are wireless and have battereies on board, so it would be surprising if they could fail due to insufficient power.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.