Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • shepster44
    Post count: 2


    I’m new to the raspberry pi scene and have only had my Pi2 for a few weeks so am still a complete noob.

    Eventually I want to make a standalone arcade but for now i’m getting it all working using my monitor and ps3 controller connected via usb to the pi2.

    Everything was going well. I downloaded the retropie image fine. Got just about every emulator I wanted working well even fba. Using the sticky from here i also managed to get the roms to read from my USB stick. So far so good.

    I then came to mame and have had nothing but problems.
    Firstly I made sure I used the correct romset…0.37b5.

    I put them in the normal mame directory on my usb and emulation station found all the roms perfectly. However when I launched the mame rom some kept stating that certain parts of the rom were missing…strange I was certain it was the correct romset.

    So Next I tried advmame, renamed the path in ES-Systems.cfg and again emulation station found these fine. But again certain roms were failing and stating parts of the rom were missing. Some roms did work fine and in both advmame and mame4all pressing the tab key brought up the menu so I was able to configure the ps3 pad.

    Still determined not to be beaten I tried the last mame emulator, mame-libretro.
    Emulation station found the roms and success! every rom now loads perfectly. However, the tab key to bring up the menu is not working and on some roms the coin and start buttons work using the ps3 controller and some they don’t. All roms exit fine using my hotkeys on the pad. But because I cannot get the menu to show up I cannot configure the controller buttons.

    My question is, does anyone know what is happening. The roms load fine in mame-libretro so they must the correct romset so why are they stating they are missing parts in mame4all and advmame. Also, any ideas why mame-libretro wont bring up the menu using the tab key. (ive tried all keys on the keyboard and ps3 buttons and none bring up this menu? Its also strange that in some roms I can use the coin and start buttons on the pad and in others I cant.

    I seem so close to getting it working but this bit has me stumped.

    Post count: 1629

    Could be worth double checking the romsets. I’ve attached the dat file.

    You can find a guide here:

    Or even try an image with an SD card.
    There is a guide here:

    Post count: 2


    Thanks for the link. It matched so i do have the correct set.

    So i decided to go back to the start and used the original retropie image on a diferent card. This time, I left the roms on the sd card rather than move them to the usb. Low and behold they worked fine!!! Couldnt believe it. It turns out that even though i had linked to my usb in es_systems config, i hadnt changed the path in the mane config. Still learning!!

    It also turns out i had left a couple of roms on the original sd card and is the reason why some were working.

    Ah well, hopefully this may help any noob like me who move mame roms to a usb will see that they also have to change the path in the mame config.


Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.