Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • cliffyboro
    Post count: 21

    Anyone have a clue about this? I did a fresh install of retropie on my pi2.

    My PS3 controller worked perfectly over bluetooth beforehand and installed fine using the script.

    Anyway, this time whenever I use the script to install now, it finds the dongle no problem but every time it tells me it can’t find the ps3 controller on USB, even though it works via USB in emulationstation and shows up on ls dev/input/. It worked perfectly any other time.

    So I paired it again using sudo ./sixpair. Worked fine and came up that the mac was set. However, when I try to use the controller, I pres the PS button and the lights on the controller flash sequentially, 1,2,3,4,3,2,1,1,2,3,4,3,2,1 then all the lights go solid and the controller goes off.

    I’ve done some searching around but can’t find anything so does anyone have a clue what’s happening with it? I’ve tried 2 bluetooth dongles (weirdly both have same mac address)

    Post count: 6

    I noticed this issue as well, and I think it has to do with a recent commit/change to the setup script. It’s failing to find the sixpair program. You can accomplish what the setup menu now seems to fail at by manually executing the sixpair program
    That will register your PS3 controller to the BT dongle on your Pi. You’ll need to restart (stop/start) the sixad service on your Pi once that’s done. Make sure hciconfig shows “UP RUNNING PSCAN
    Then press the PS button and after a second or two it should register.

    Hope that helps.

    Post count: 21

    Hey Jiggawatt thanks for the reply.

    Hmmm it kind of worked but then I got same sequential lights and off, so maybe I did have them paired properly but just didn’t see the following error until I now. This is the output;

    sixad-bin[2726]: started
    sixad-bin[2726]: sixad started, press the PS button now
    sixad-sixaxis[2729]: started
    sixad-sixaxis[2729]: Connected 'PLAYSTATION(R)3 Controller (04:98:F3:33:BC:52)' [Battery 00]
    sixad-sixaxis[2729]: Bad Sixaxis buffer (out of battery?), disconneting now...

    Now, both controllers have been fully charged. According to the PS3, they are both at 100%.

    I think I’ll leave them on charge for a couple of hours again and see if the ps3 is just showing it wrong for some reason although, seems unlikely doesn’t it?

    Post count: 21

    Ok, thanks jiggawatt, I finally got it done! The batteries where fine, as soon as I plugged them in ps3 they went to 100%.

    Anyway, for records sake all I did was write the RetroPie image to the SD card again and instead of updating the RetroPie Setup script, I just resized the partition and went straight to install PS3 controller from the script. Once again, it didn’t detect the PS3 controller over USB so I ran;

    sudo /opt/retropie/supplementary/ps3controller/sixpair

    and it paired fine.

    Stopped sixad using;

    sixad --stop

    then started it again using;

    `sixad -s’

    and it connected first time.

    So thanks again and anyone else having the ‘PS3 Controller not found’ error using the PS3 driver install on the script should give these instructions a try.

    I’ve tried to use as many exact terms as possible so hopefully people can find this from Google.

    Thanks again

    Post count: 10

    I had the bad sixaxis buffer (out of battery) including the sequentially flashing of the lights since retropie 2.6 (before that i had no trouble connecting 2 ps3 controllers over bluetooth), even though i use original ps3 controllers and a working bluetooth dongle.

    In Retropie 2.6 i fixed it like this:

    Via the retropie setup (RetroPie-Setup/ menu I chose setup and after that I installed PS3 controller driver-mod 315 (instead of the usual ps3 controller driver 314). After it installed I did another sixpair command and after a reboot it worked (and kept working). So I guess it had something to do with the original driver not being compatible with 2.6, it did however worked with 2.5.

    In the latest Retropie (3.0 beta 4) this option isn’t available anymore. So the only way I could fix it was by setting legacy to 2:

    go to


    sudo nano sixad

    set legacy = 2

    save, then:

    sixad –stop
    sixad -s

    After reboot, everything works and I can pair 2 controllers (I haven’t tested more), however according to sixad forums you lose the accelerometer or rumble). The leds work but the rest I haven’t yet noticed. I hope in future versions of retropie the problem gets fixed permanently.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.