Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • Anonymous
    Post count: 7


    I was trying to troubleshoot multiple GPIO button input problems and didn’t want to have to reboot and get back into terminal each time I was testing so I changed ES not to start on boot through the and now it just goes to a black screen after boot. Please tell me there is an easy for this =\

    Thank you in advance!

    Post count: 1827

    What was your configuration before that? Did you boot into LXDE or into the command shell?

    You should still be able to use SSH to log into your RPi. Could you post the content of the file /etc/inittab here? That is where the critical changes were probably made.

    Post count: 177

    hi petrockblog,

    I love your work..

    I have a simular issue, I am trying to make a RetroPie install using the raspbian image for berryboot, last night I run the full install of the retro-pie script, and everything was success, but when I then run the retro-pie setup and set the system to start emulationstation on boot, it reboots, but just goes back to LXDE, have I done something wrong? as I was hoping that it would reboot to emulationstation and I would be sorted.

    Im sure I have probably just done something silly/wrong, and would love if you could point me in the right direction..


    Post count: 1827

    Emulation Station must not be started from LXDE, because of the way Emulation Station uses the graphics device!
    You need to exit LXDE, starting Emulation Station should work from command line then. If you enable the autostart on boot for Emulation Station, you need to disable the autostart of LXDE as well.

    Post count: 7

    Here are the steps I have done.

    1. Followed all instructions on the wiki
    2. Set keyboard, locale, mem split to 256 (rev 2 board)
    3. I did a binary install because I only wanted SNES/NES/Megadrive. I included all non-emulator installs except for SNESDev.
    4. Added roms
    5. Ran scrapper
    6. Installed GPIO game adapter
    7. Enabled SNES GPIO tool
    8. Installed pikeyd (it polls PGIO pins to simulate a virtual keyboard. I couldn’t figure out how to get SNESDev to do multiple buttons so I went with pikeyd)
    9. Installed pikeyd: added the make file to /etc, added “i2c-dev” in /etc/modules, added pikeyd.conf to /etc, commented out “blacklist i2c-bcm2708” in /etc/modprobe.d/raspi-blacklist.conf, and added “usr/local/bin/pikeyd -d” to /etc/rc.local.
    10. Added custom splashscreen

    Now when I start, it goes to the splashscreen, then goes black. I tried with RCA and HDMI and no luck. I have also tried un-doing everything I did with pikeyd, but it still does not work correctly. For the record, I have gotten everything to work with pikeyd, and without on other builds.

    Post count: 7


    # /etc/inittab: init(8) configuration.
    # $Id: inittab,v 1.91 2002/01/25 13:35:21 miquels Exp $
    # The default runlevel.
    # Boot-time system configuration/initialization script.
    # This is run first except when booting in emergency (-b) mode.
    # What to do in single-user mode.
    # /etc/init.d executes the S and K scripts upon change
    # of runlevel.
    # Runlevel 0 is halt.
    # Runlevel 1 is single-user.
    # Runlevels 2-5 are multi-user.
    # Runlevel 6 is reboot.
    l0:0:wait:/etc/init.d/rc 0
    l1:1:wait:/etc/init.d/rc 1
    l2:2:wait:/etc/init.d/rc 2
    l3:3:wait:/etc/init.d/rc 3
    l4:4:wait:/etc/init.d/rc 4
    l5:5:wait:/etc/init.d/rc 5
    l6:6:wait:/etc/init.d/rc 6
    # Normally not reached, but fallthrough in case of emergency.
    # What to do when CTRL-ALT-DEL is pressed.
    ca:12345:ctrlaltdel:/sbin/shutdown -t1 -a -r now
    # Action on special keypress (ALT-UpArrow).
    #kb::kbrequest:/bin/echo "Keyboard Request--edit /etc/inittab to let this work."
    # What to do when the power fails/returns.
    pf::powerwait:/etc/init.d/powerfail start
    pn::powerfailnow:/etc/init.d/powerfail now
    po::powerokwait:/etc/init.d/powerfail stop
    # /sbin/getty invocations for the runlevels.
    # The "id" field MUST be the same as the last
    # characters of the device (after "tty").
    # Format:
    #  <id>:<runlevels>:<action>:<process>
    # Note that on most Debian systems tty7 is used by the X Window System,
    # so if you want to add more getty's go ahead but skip tty7 if you run X.
    1:2345:respawn:/sbin/getty --noclear 38400 tty1 
    2:23:respawn:/sbin/getty 38400 tty2
    3:23:respawn:/sbin/getty 38400 tty3
    4:23:respawn:/sbin/getty 38400 tty4
    5:23:respawn:/sbin/getty 38400 tty5
    6:23:respawn:/sbin/getty 38400 tty6
    # Example how to put a getty on a serial line (for a terminal)
    #T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100
    #T1:23:respawn:/sbin/getty -L ttyS1 9600 vt100
    # Example how to put a getty on a modem line.
    #T3:23:respawn:/sbin/mgetty -x0 -s 57600 ttyS3
    #Spawn a getty on Raspberry Pi serial line
    T0:23:respawn:/sbin/getty -L ttyAMA0 115200 vt100

    This most recent attempt I did everything through ssh and terminal. The only time I restarted was after expanding the SD card size. I never went into ES on this try.

    Post count: 1827

    SNESDev and the gamecon driver must not be installed at the same time, because thez do interfere with each other when accessing the GPIO pins. I have no experience with pikeyd, but it sounds as if it also accessed the GPIO pins. This would mean that only one of these three programs must run at the same time.

    For debugging, I would also suggest to disable the custom splashscreen to see the console output during boot.

    Post count: 7

    Is it possible to use the GAMECON driver or SNESDev for 2 snes controllers and poll 2 GPIO buttons? I tried taking a look into the c code, but I am not experienced enough with programing to figure out how to manipulate it. Would you (or anyone) be willing to provide me with this for a small fee or donation?

    Basically all I want is 2 snes controllers to work in the games and a button on GPIO pin_15 and pin_18 to enter a letter on one press so I can program the game for reset/escape. I assume it’s just a matter finding the current button poll code but I’m not sure where/what to look at.

    Thank you very much for the help already provided. This community and software is great!

    Post count: 1827

    Making SNESDev more configurable is actually on my to-do list. I do not know when exactly I will find time for that though.

    Post count: 7

    Understandable, seems like it’s a big undertaking. Is there any way you can point me in the right direction of how to do it? Like what files I have to edit to add in another button and make it work on 1 button press and not 3?

    Post count: 1827

    The critical parts of the source code can be found in the lines starting at

Viewing 11 posts - 1 through 11 (of 11 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.