Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • afriendnamed5
    Participant
    Post count: 4

    Ok, I’ll try and make this short and I would be extremely grateful of any help aside from what I’ve tried already.

    I have the 1.4 version of the RetroPie GPIO Adapter. I have a rev.2 model B pi that I’m building into a SNES case, and want to use the original controller board from the SNES.

    I’ve hooked up the adapter to the pi’s GPIOs and the SNES ports, as per the instructions on this site, and also as per every other way I can find online of doing it. Currently it’s setup the ‘official’ way and still not working.
    I’ve even sought help from ModMyPi (who I purchased the adapter from), and they have verified my setup is right.

    Using the latest RetroPie SD image, here’s what I’ve done with regards to SNESDev and joytest:
    – updated RetroPie binaries and setup script. Used setup script to set adapter version as “1x” (as its a 1.4), and set SNESDev to start at boot. Reboot.
    – Booted into Emulationstation, 2 gamepads detected (which can only be the SNES ports as thats all there is plugged in aside from the keyboard). No buttonpresses detected.
    – uinput module is loaded. SNESDev service is running. Jstest on ports 0 and 1 show as SNES gamepads, but again will not detect buttonpresses.
    – Something odd: all buttons on jstest state “off”, but axes constantly state -3276 something or other.

    I’ve checked for shorts at both ends and it’s all fine, and I’ve unsoldered, cleaned and re-soldered several times. I’ve also re-imaged the SD several times to start over. Nothing I do seems to produce a different result.
    I’ve tried with an official SNES pad and a 3rd party Competition Pro.

    I know that rev.2 pi uses a different GPIO pinout to rev.1, so is there anything else I need to do to the adapter or my SNESDev configs to tell it I’m using a rev.2? Can’t find any info online about telling SNESDev drivers about using rev.2 pins.

    Apologies for the long post, but this has been making my brain hurt for over a week now, and I figured it’d be more useful to anyone that can help if I mention what I’ve already done.

    BTW, I also tried using the gamecon drivers (from the setup script) and couldn’t for the life of me figure out how to set that up, so abandoned it. If anyone thinks they’re worth using and can shed some light step-by-step for rev.2 boards then I’ll be over the moon.

    petrockblog
    Keymaster
    Post count: 1827

    Just to make sure: Can you show the content of /etc/snesdev.cfg?

    Also, does the button work? You could test this with the little test program that comes with SNESDev, see https://github.com/petrockblog/SNESDev-RPi/tree/master/supplementary/testButton.

    thehofl
    Participant
    Post count: 3

    Hello. I am also encountering the same issue. When Emulation Station starts, a message is displayed that 2 controllers were found. However, no button pressing is registered. The button on the GPIO adapter is also not registering. My RPI2 is rev1.1. I am using a v1.2 GPIO adapter. Any assistance/advice is greatly appreciated.

    Also, below is my “snesdev.cfg” contents.

    —snesdev.cfg—
    # Configuration file for SNESDev, the driver for the RetroPie GPIO Adapter.

    # Revision of RetroPie GPIO Adapter. Options: “1x”, “2x”
    adapter_version=1x

    # button enabled? Options: 0 (disabled), 1 (enabled)
    button_enabled=1

    # game pad 1 enabled? Options: 0 (disabled), 1 (enabled)
    gamepad1_enabled=1

    # gamepad 1 type. Options: “nes”, “snes”
    gamepad1_type=”snes”

    # game pad 2 enabled? Options: 0 (disabled), 1 (enabled)
    gamepad2_enabled=1

    # gamepad 2 type. Options: “nes”, “snes”
    gamepad2_type=”snes”

    —end of file—

    EDIT: The GPIO adapter works perfectly on my RPI1.

    petrockblog
    Keymaster
    Post count: 1827

    Does it help if you recompile and reinstall SNESDev?

    thehofl
    Participant
    Post count: 3

    I did try installing everything from the image file that is provided. I also manually installed everything from the steps on https://supernintendopi.wordpress.com/ and http://tinyurl.com/kkmvfgc…

    As i was replying, i tried the steps on the following site. It worked for me!
    https://github.com/petrockblog/SNESDev-RPi

    EDIT: Thank you for your assistance petrock! :)

    petrockblog
    Keymaster
    Post count: 1827

    Glad that it is working for you now!

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.