Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #84019


    This is my first post. First off I’d like to thank the creators of RetroPie, it’s a very fun project! I’m really loving it and discovering Linux and the Raspberry Pi at the same time (I’ll gladly admit that I’m a total Linux noob).

    Now for my problem: the EmulationStation menu displays slightly larger than my TV screen. I’ve been on numerous sites and I’ve tried editing the overscan settings several kinds of ways in the boot/config.txt file via “sudo nano”, but nothing seems to work. Some settings have affected how the command line is displayed when I hit F4. But the settings don’t change a single thing about how the EmulationStation menu is displayed, and the ES menu borders are still cropped by my TV screen (I’m using an HDMI input). It’s not by much, but for example the text at the bottom left of the screen is halfway out of my screen… if anyone could point me in the right direction it’d be greatly appreciated. Thanks!


    Try this video, and check the link in its description:

    Your issue may relate to this line:


    First off I apologize for not answering sooner. Just move into a new house so things are pretty busy. :-)

    Second, thanks for answering my question. :-) :-) You’ve posted a TON of very useful stuff, thank you!

    So I did go through your video. I have tried to add the “overscan_scale=1” line to the config.txt file and did not notice any difference: the emulation station screen still seems too large for the TV screen and it’s cut off in all 4 directions (that is the original problem I’m trying to solve).

    I’ve tried to uncomment the overscan_left/right/top/bottom values and set them to 30 but again for the emulation station menu it makes no difference. It does add a margin when I go into the terminal by hitting F4 though…

    I also tried changing the mode to 4 in the fba emulator in es_systems.cfg, it also made no difference.

    I figured I should match the hdmi_mode in config.txt to what is in es_systems.cfg so I uncommented the hdmi_mode line and assigned it a 4 value (so hdmi_group=1 and hdmi_mode=4). Did not solve the issue in emulation station, but now the terminal is easier to read! :-D

    So I’ve tried all of that and I still have the exact same issue (in fact it seems like none of the above changed a single thing about it): when I am in Emulation Station, the menu seems too big for my screen. For example, on the bottom left corner, the bottom of the “MENU” letters are cut off and what is on the left of “MENU” is off my screen. I wish I could fix that, I’m not sure what it is. I don’t think it’s my TV, I’ve tried all of the display format and none of it fixes the problem… I’m using the HDMI input and it’s a 1080p display… Thanks.


    To get a benchmark can you try the same Pi on another TV?


    [quote=85332]To get a benchmark can you try the same Pi on another TV?[/quote]

    Sure, I’ll try it on my PC monitor and report back, it has an HDMI input.


    Hey guys hoping someone can help me with my overscan issues.
    firstly I’m a complete amateur when it comes to linux.
    secondly I wanna say this project is awesome so far Ive had very little trouble, even as a total novice, getting this thing up and running. In large part thanks to Floob and his youtube channel. Retropie 3.3 is great too! Ive seen from watching videos of earlier releases that you guys have put in an incredible amount of effort simplifying the UI and making key features more accessible. from a complete noob Thanks!

    *so the issue Im having is the “black box” around the display
    all the emulation/controls run great but I just cant seem to ditch this box.

    heres what I’ve got and hopefully all relevant information

    Raspberry Pi 2 model b running Retropie 3.3 with a vizio 1080p tv for display

    I’ve overclocked the raspberry to the pi2 setting and split the ram to run 50/50 with the cpu and gpu. (side note my max setting is 128mb each so totaling 512mb but I have 1gig of ram so shouldnt I see 512 each?)

    heres what I’ve tried so far-
    In the raspi-config menu (accessed from the retropie menu in Emulation Station) I went to 9 Advanced Options
    then A1 Overscan and I get an error when trying to enable or disable overscan

    “There was an error running option A1 Overscan”

    so I checked out Floob’s video on overscan but when I go to this directory

    cd /boot
    sudo nano config.txt

    this is all I see


    so am I in the wrong directory?
    or am I missing something obvious (most likely.)
    why do I get the error message and where are these settings?

    I flashed retropie 3.3 on to a blank sd card I didnt do anything with Rasbian first so did I miss some important config files by not installing Rasbian first?

    hope this all makes sense

    I appreciate the time


    *edit that math is totally wrong on the ram. its a total of 256 so why cant I get 512 each? sorry this is the wrong place to post this. one thing at a time.


    Just to make sure you have all the relevant info in the /boot directory, can you confirm you are using image 3.3.1?


    Hey floob yes im running 3.3.1 based on the .img I downloaded.

    is there a command to check this on the pi?

    Ive done a clean install to see if that would help but nothing has changed.

    when I change to the boot directory and open the configs file I see the same 4 lines as before. also still getting the error message when trying to enable or disable overscan in the menu.

    thanks for the response.

    by the way I watched your video on the command line and it has been invaluable to me. I can actually get around the terminal now. thanks man.


    I’ve just tried a clean install of 3.3.1 and there is a full config in /boot/config.txt
    I’m using the RetroPie 2 image of 3.3.1 on Wheezy – maybe you can re-download to double check?


    Ill try that.
    when you say wheezy are you saying you installed retropie on top of wheezy?
    Im still thinking I may have missed something in the install process.
    could you explain that a little? (sorry if this seems moronic)
    All I wanted to do with the Pi is use something like retropie so when I got it all I did was take it out of the box put it in a case flashed a brand new 32gig sd card with the torrent download of RetroPie 3.3.1 (not the berryboot version) using apple pi baker. then plugged the sd card in and away we went. then I did that entire process again when I didnt have anything in the config.txt

    So a couple other things if you could clear up for me that be awesome.

    1. Do you or anyone youve talked to get an error message when trying to enable disable the overscan in the raspi-config menu?

    2a. I was under the impression that the config file would have the kinds of settings I’ve seen other people using but commented out and I could remove the # to use that setting. and change the values to the right of the = to further adjust. Is this correct?

    2b. even if the file is empty I should be able to add these settings using sudo nano is that correct?
    but when I type in the overscan settings for example disable_overscan=1
    and then ctrl-x and save the file. then reboot. nothing changes. the commands are saved in the file when I go back to the file they’re in there but the Pi doesn’t seem to read this file.

    3. through the googling Ive done I found these commands to view settings

    when I type vcgencmd get_config int I get a list that displays the overscan settings along with the cache and some others but its just a list. so those settings are somewhere right? but not in the config.txt so where else could they be and why wont the settings I enter in the config file override these?

    4. how can I access the root directory? I get permission denied using cd /root. and then when I use sudo Im told command not found.



    okay I think you mean Wheezy as opposed to Jessie
    I downloaded Wheezy standard via the torrent link.
    3.3.1 for Raspberry Pi 2




    As I suspected it was all on my end. somehow I managed to download version 3.3.
    When I finally got home from traveling for the holidays I double checked the .img I downloaded on my Mac and it was version 3.3 not 3.3.1. Still have no idea how I managed that.

    So fresh download of 3.3.1 then Fresh install and
    no overscan error in the GUI so on reboot BLACK BOX IS GONE (sorry Im overly excited about fixing this)

    the config.txt file is populated with the basic settings I need and I can make changes.

    Sorry to waste anyones time. thanks for the “help” Floob
    Sincerely thank you for the responses and resources and letting me ramble…


Viewing 13 posts - 1 through 13 (of 13 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.