Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • octubrq
    Participant
    Post count: 46

    sorry for my english .I have correctly configured hindfoot and raspberry, but some games are slow or do not have good sound and have read that not enough power the raspberry. has overclock to 900 mhz. Retropies? Olimex is fully compatible with 20? thanks

    gizmo98
    Participant
    Post count: 452

    I will check it out this week.

    octubrq
    Participant
    Post count: 46

    ok thanks!!

    octubrq
    Participant
    Post count: 46

    Have you try it?

    gizmo98
    Participant
    Post count: 452

    I have tried it, but i wasn’t successful. I could not boot from a SD card. It seems to be the A20 needs a micro SD card. I ordered one and will check it out this week. ;-)

    octubrq
    Participant
    Post count: 46

    to see if you’re lucky!

    octubrq
    Participant
    Post count: 46

    I read that does not support the graphics card. Please see if you can confirm

    gizmo98
    Participant
    Post count: 452

    RetroPie-Setup is not compatible with the olimex debian image at the moment. RetroPie-Setup cannot disable the autostart of Xorg/XFCE and emulationstation cannot start if Xorg is running.

    With minor changes of the RetroPie-Setup Script it should be possible to run emulation station and Retroarch cores.

    octubrq
    Participant
    Post count: 46

    Shame!thanks for all

    gizmo98
    Participant
    Post count: 452

    There is no defined way to target different platforms at the moment. I will try to fork the current RetroPie-Setup for olimex A20.

    But first of all i will disable the autostart Xorg manually and check out if emulationstation is running.

    octubrq
    Participant
    Post count: 46

    thanks my friend

    gizmo98
    Participant
    Post count: 452

    Update:
    -I modified retropie setup script.
    -You can build and run emulationstation. Emulationstation starts only if X is running. It runs slow as hell, because it uses mesa GL libs. GLES builds will not start at the moment. Should be a emulation station problem.
    -You can build and run Retroarch. At 720p the framerate drops to 40-50Hz. Shaders cannot be used (too slow). 480p or 576p should be fast enough.
    -The Mali kernel module r3p0 is too old. Only one core of the MALI400MP2 dual GPU is used. If the kernel module r3p2-relxx could be build the framerate should be much better.

    gizmo98
    Participant
    Post count: 452

    Update:
    -It is possible to build SDL2 and EmulationStation with GLES support. Runs really smooth under X.
    -It is also possible to compile RetroArch with GLES support.
    -GB and SNES cores are running atm. Cannot start PCSX, cannot build pocketsnes. Have not tested other cores.

    gizmo98
    Participant
    Post count: 452

    Update:
    -GB, GBC, SNES, GENESIS, MASTERSYSTEM and PSX are running fine. (resolution 576p)
    -Cannot build mupen64plus-rpi and gasp.
    -Shaders are slow as hell. Smooth video runs good.
    -SNES: Secret of Mana 2, Starwing and Super Mario RPG run at full speed.
    -PSX: Gran Turismo runs good.

    Source:
    sudo git clone –depth=0 git://github.com/gizmo98/RetroPie-Setup.git

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.