Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • flavad99
    Post count: 16

    I realize this probably gets asked a lot but I have been through some of the steps outlined on the web and am still having trouble getting sound.

    I installed Retropie a few days ago, NES, SNES, Genesis working great, still ironing out the details on PSX / Neo Geo (Haven’t had time to look at the BIOS solutions out there yet). I have a Retropie 2 and installed the Beta 3.0 version. Built from an SD image, SNES gamepad, keyboard, mouse, and USB plugged in. Games on the NES, SNES, Genesis emulate fine, however, I get no sound. I am connecting through an hdmi monitor.

    I followed the steps here

    but didn’t receive any luck. The only thing I can think of is that I am rebooting (sudo reboot) afterchanging the settings. I have tried returning directly to the emulationstation screen using startx, but my pi freezes on a white screen when I try this.

    Any ideas? Thanks for any help you could provide, as you might tell, I have no programming experience prior to getting one of these.

    Post count: 1827

    You dont use startx to load emulationstation you just type emulationstation.

    you need to reboot if adjusting config.txt, but I can’t advise further other than what is on that page and other threads on the forum with ideas. usuaully hdmi_drive sorts it if using dmt mode and you want sound over hdmi.

    Post count: 22

    Post your config.txt

    Post count: 16

    from the /boot/config.txt file


    Overscans equal to 16


    Is this sufficient? Thanks!

    Post count: 16

    Fixed it. I saw this on another forum. You can’t just edit the hdmi_drive=2 within the pre-existing text, you have to add an additional line at the bottom. Write the text to the configuration file, reboot, and my sound worked.

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘General discussion’ is closed to new topics and replies.