Tagged: 

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • jzp74
    Participant
    Post count: 10

    Hi all,

    I flashed the latest version of retropie (v1.8.1) on an SD card and gave it a spin. Vice seems to be working perfectly except for one thing: no sound whatsoever.

    I do hear sound effects in emulationstation so sound is working but not in Vice. I tried all possible sound output settings in Vice: alsa, oss, etc but none of them works.

    Any help would be greatly appreciated.

    jzp74
    Participant
    Post count: 10

    Any ideas someone? Please help.

    jzp74
    Participant
    Post count: 10

    Is anyone actually using Vice to play games? And did you get sound to work?

    Thanks

    FreezX
    Participant
    Post count: 13

    What are you putting audio out over, HDMI or the audio jack?

    jzp74
    Participant
    Post count: 10

    Flashed 1.9.1 version but same result.

    I’m running audio over hdmi. Works fine in emulationstation but no sound in Vice. Tried every suggestion I cound find but no sound…

    Any ideas someone.

    jzp74
    Participant
    Post count: 10

    Ok, here’s what I found out the last few days:

    It seems that some HDTV’s have trouble playing sound over HDMI. The most common solution to this problem is to uncomment the line
    hdmi_drive=2
    in your config.txt. This forces your tv to hdmi mode (instead of dvi) so that sound will be send over hdmi. That solves most of the problems. See http://elinux.org/RPiconfig for more details of all the config.txt options.

    It did not in my case unfortunately so I had to dig deeper. It seems that some tv’s have difficulty with playing mono sounds over hdmi. My tv plays stereo over hdmi just fine but refuses to play mono sounds. See this page for some more information: http://elinux.org/R-Pi_Troubleshooting#Sound. I tried uncommenting the lines:
    hdmi_group=1
    hdmi_mode=4
    of my config.txt (read this suggestion somewhere). This forces your tv to 720p and CEA mode. Still no sound.

    Read somewhere else that in some cases adding the line
    hdmi_force_edid_audio=1
    might also do the trick. This forces all sounds over hdmi. No luck.

    I then started thinking that maybe Vice supports sound output in stereo in some way. I started browsing through the docs and found that this option indeed exists! But only in the v2.4 and Retropie currently support v2.3.

    I then found this post that explains how to install binaries of v2.4 on your pi: http://www.raspberrypi.org/forums/viewtopic.php?p=505178. I installed the binaries and the option to play sound only in stereo works perfectly!

    Case closed for me :-) Hope I can help some others with this explanation.


    @petrockblog
    : Can you edit your script to facilitate Vice v2.4? Here is a link to build from sources: http://www.raspberrypi.org/forums/viewtopic.php?p=504655

    gizmo98
    Participant
    Post count: 452
Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.