Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • zbh23
    Participant
    Post count: 8

    Hello,

    Long story short, I am using 8bitdo NES30 controllers for 1P and 2P.

    Everything is working great except the select key on 1P controller is mapped to the “n” key. This key was originally assigned to input_shader_prev in the retroarch.cfg

    I have changed this key assignment in /opt/retropie/configs/all/retroarch.cfg to another key. However the “n” key still changes to the previous shader.

    I have even removed the key assignment to input_shader_prev and the “n” key still changes to the previous shader.

    Any suggestions would be appreciated.

    Floob
    Member
    Post count: 1629

    Is there a reference in your controller file to the next shader – the controller file in

    /opt/retropie/emulators/RetroArch/configs/

    My hotkey video may help:

    zbh23
    Participant
    Post count: 8

    I just checked and there was a retroarch.cfg in

    /opt/retropie/emulators/RetroArch/configs

    I commented out the lines regarding input shader next and previous; however the issue still exists.

    Floob
    Member
    Post count: 1629

    When you start a game, is there yellow text at the bottom of the screen briefly?
    This means you are using a controller file in
    /opt/retropie/emulators/RetroArch/configs
    Check the dates on the files, as a more recent date would indicate that is your file.

    You may want to check the contents of the retroarch.cfg in
    /opt/retropie/configs/{systemname}/retroarch.cfg as well, as that can override the main one at:
    /opt/retropie/configs/all/retroarch.cfg

    zbh23
    Participant
    Post count: 8

    At the start of a game there is no yellow text. The only yellow text I see is after hitting the “n” key and the shader selection dialog is displayed.

    If it helps the controllers I have are actually configured as keyboards (hence why I need the use of the “n” key). I have their configuration setup in the main retroarch.cfg here:

    /opt/retropie/configs/all/

    so there shouldn’t be anything overriding the primary retroarch config via the autodetect controller process.

    As for the emulator specific config (I am using snes when the issue occurs); the files doesn’t contain any key bindings, the only lines in that file are related to a shader I explicitly selected and video smoothing properties.

    Floob
    Member
    Post count: 1629

    What is this value in your main retroarch.cfg
    input_enable_hotkey

    I’m thinking it reads “nul” as that would mean it would kick in.
    If you changed it to read “alt” then you would have to press “alt” to make that hotkey function work.

    The video above should cover the different hotkey configs.

    zbh23
    Participant
    Post count: 8

    That is the thing, the “n” key binding is my entry for input_enable_hotkey (so that I can press “n” and another key to escape the emulator).

    This functionality works, but if I simply press “n” it also conducts the input_shader_prev action.

    Floob
    Member
    Post count: 1629

    If you remove the input_shader_prev value altogether it may well default to its ‘n’ value.
    Have you tried setting input_shader_prev to a value other than ‘n’?

    Although I would just be tempted to have “alt” as my hotkey.

    zbh23
    Participant
    Post count: 8

    Yes I have tried setting the value to a different key, placing the value to nul, and commenting out the line to no avail.

    Floob
    Member
    Post count: 1629

    Could you post your retroarch.cfg as an attachment? You’d need to rename it .txt.

    Does it work fine if you set your hotkey to alt instead of n?

    zbh23
    Participant
    Post count: 8

    So I tested using alt as my hotkey assignment and it worked, then I tested a few other keys that are mapped in my controller setup and all of the keys I tested were successful.

    So it seems that assigning “n” as the hotkey causes an issue due to the default “n” as the input_shader_prev key.

    Floob
    Member
    Post count: 1629

    Thats great! Could you mark this one as resolved?

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.