Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • jimmifett
    Participant
    Post count: 3

    Running 2.6.0 on an rpi2.
    Trying to get Star Tropics working under NES, updated Retropie script, installed Nestopia, now emulation station keep throwing an error for all NES games.

    /opt/retropie/supplementary/runcommand/runcommand.sh: line 203: _SYS_: command not found

    steps from fresh image installation:

    apt-get update
    apt-get upgrade
    Retropie-Setup/retropie_setup.sh
    Update Retropie Script (installs some xml thing)
    reboot
    Retropie-Setup/retropie_setup.sh
    Install individuals emulators from bin or source
    lr-nestopia
    binary
    rebooot

    attempt to run any NES game, get above error.

    Many thanks,

    -Jim

    Floob
    Member
    Post count: 1629

    Does that game not work under /home/pi/RetroPie/roms/nes/?

    jimmifett
    Participant
    Post count: 3

    Star Tropics 1/2 use MMC6 vs MMC3. Apparently some emulators have problems with this. Star Tropics for instance, get stuck at name registration, making game unplayable. Nestopia supposedly has this working.

    gizmo98
    Participant
    Post count: 452

    @oldchocobo
    There is a color palette core option.

    @all
    RetroPie-Setup script was massively overhauled last week. I think we have reached a point of no return for retropie 2.6.0 images. It is necessary to do at least a binary update before you can do source based installations again. A binary update can overwrite all of your changes. So please think twice before you do a binary update. Always do a backup before you update.

    cacophony555
    Participant
    Post count: 126

    @gizmo98, perhaps it’s time for a new image to be released ?

    jimmifett
    Participant
    Post count: 3

    Performed a full binary installation, seemed to fix the error message I was getting.

    Unfortunately, still having issues with star tropics. Load the lr-nestopia core, load the rom, and it totally freaks out.

    Perhaps star tropics will just not be playable, unless someone else can get it working with fceumm.

    taalas
    Participant
    Post count: 56

    I ran into the same problems when updating/installing lr-genesis-plus-gx.

    I previously had updated ES and the simple theme, installing emulator cores breaks es_systems.cfg due to the new emulator choosing mechanics I think.

    If I perform a binary update (meaning the first point in the setup script, right?) what do I loose in terms of configuration?

    Thanks!

    Anonymous
    Inactive
    Post count: 5

    Any update to this? I get the same issue when running a binary update on Snes9x-next

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.