Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #101452

    I’m trying to configure my NeoGeo X arcade stick with Retropie but have not been able to get Emulationstation nor Retroarch to recognize it. When I test the joystick utilizing jstest it reads the joysticks input perfectly fine. When I try to configure it through Retroarch, it skips past the key prompts and says that my configurations have been saved.

    I’m currently using Retropie 3.0 beta 4 and have tried beta 2 as well. I have also have updated the retropie and the setup script before troubleshooting with clean installs each time. Any suggestions would be greatly appreciated as I not found anything online that directly addresses my issue, thanks.

    btw I’m using a Raspberry Pi 2.


    I’m having the same problem.


    Have you tried on older Retropie versions? I read of there being compatibility with piplay, which is another Raspberry Pi OS made for gaming and emulation. I’m going to work on it some more tonight but i’m close to giving up and just replacing the circuit inside the arcade stick with a compatible one…

    there’s also another thread where someone mentions the NeoGeo X issues but I don’t believe the questions posed in that thread lead to a solution or fix but it’s worth a read.

    Neo Geo X joystick with Retropie 2.6 or 3.0


    I found that retroarch handles the axis inputs differently than jstest, which could be the reason for retroarch closing prematurely upon reaching the input prompt screen with the NeoGeo X joystick. When I run retroarch-joyconfig with -d linuxraw I am able to receive input from the NeoGeo X joystick. Unfortunately this did not produce a config file for the joystick. So I created a NeoGeoX.cfg file in the retroarch-joypads directory and ran retroarch-joyconfig using the following commands:

    ./retroarch-joyconfig -d linuxraw -o /opt/retropie/configs/all/retroarch-joypads/NeogeoX.cfg

    This basically forced the output of retroarch-joyconfig to the specified directory, which it did so successfully. But this is where I ran into bigger problem, the output that was written to the NeoGeoX.cfg was missing all of the device information and the config information recorded was missing the axis inputs as well.

    This brings me back to the format in which udev records axis inputs vs linuxraw.

    Tomorrow I will try to find and install an older version of retropie that supposedly has better linuxraw support already in retroarch and compare the retroarch config files.


    I’ve been having exactly the same problem with the Neo Geo X stick.
    I don’t suppose you ever got this working or came up with another solution. Unfortunately I’m completely in the dark! The latest version I have working is 1.7 so not sure if that’s of any help…


    I have managed to get this working somewhat. This works for Version 3.2.1, but later versions removed the retroarch-joyconfig tool.

    cd /opt/retropie/emulators/retroarch/bin/
    sudo ./retroarch-joyconfig -d linuxraw -j 0 >> /opt/retropie/configs/all/retroarch.cfg

    Then in retroarch.cfg uncomment and enter linux raw as the joypad driver

    # Input device driver. (Valid: linuxraw, sdl, dinput)
    # input_joypad_driver =

    I’ve copied the input for a second player and this does work, however, I’m currently stuck on a couple of points.

    Firstly, emulationstation still does not recognise the NeoGeoX Joystick (when retroarch is running it names it but says “not configured”). This is frustrating because it means using another controller to select the ROM, then having to switch.

    Secondly, when both Neo Geo Joysticks are plugged in, one of them will register 2 credits for every button press (the other does not) – weird but not a deal breaker. Not sure if there is an obvious reason for this.

    I’m happy to upload the .cfg file if that helps but would definitely appreciate any help getting emulationstation to recognise the joystick!

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.