Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • chito
    Participant
    Post count: 137

    so ive created an overlay for NeoGeo pocket but im having strange problems. It seems that even though I have these 2 lines in my ngp/retroarch.cfg

    video_fullscreen_x = 1920
    video_fullscreen_y = 1080

    the systems displays it at width of 850 (i tested this using custom_viewport_x = 850)

    this is throwing off all my coordinates and its really frustrating. I cant understand why it is outputting the system at the wrong width
    here is my file in full and the image used attached

    video_fullscreen_x = 1920
    video_fullscreen_y = 1080
    custom_viewport_width = 800
    custom_viewport_height = 760
    custom_viewport_x = 563
    custom_viewport_y = 161
    aspect_ratio_index = 22
    input_overlay = /opt/retropie/emulators/retroarch/overlays/1080p_4-3/NeoGeoPocket_1080p.cfg
    input_overlay_enable = "true"
    input_overlay_opacity = 1.000000
    input_overlay_scale = 1.000000
    
    # Settings made here will only override settings in the global retroarch.cfg if placed above the #include line
    
    input_remapping_directory = /opt/retropie/configs/ngp/
    video_smooth = false
    video_shader = /opt/retropie/emulators/retroarch/shader/hq4x.glslp
    # video_shader_enable = true
    
    #include "/opt/retropie/configs/all/retroarch.cfg"
    chito
    Participant
    Post count: 137

    How do i get the screen to output at 1920 x 1080???

    maybe its just a weird issue with my setup

    chito
    Participant
    Post count: 137

    Found the issue: the retro arch menu was on the wrong setting. I had to set it to use the config file resolution. I wonder if this is the case for other systems not being on the correct default

    Floob
    Member
    Post count: 1629

    Are you talking about this line in the file you show above?
    aspect_ratio_index = 22

    chito
    Participant
    Post count: 137

    no. i had to use the menu that comes up when you are loading a rom. in the settings for the emulation. had to use the option for “8 select retroarch render res for lr-mednafen-ngp (config)” > “choose retroarch render resolution” > 6 use config file resolution. it kept ignoring the setting in my config

    dustloop
    Participant
    Post count: 22

    Sorry to go off track but did you make that border yourself or did you get it somewhere else?

    I have been wanting to find borders like that for weeks!

    chito
    Participant
    Post count: 137

    yes i made it. And there more on my github
    along with the settings.
    https://github.com/israelperez/retro-gaming/tree/master/bevels-overlays/1920×1080

    dustloop
    Participant
    Post count: 22

    Those are real good man! Real talent right there! Do you mind if I use this on my setup??

    chito
    Participant
    Post count: 137

    of course not. go ahead and use them

Viewing 9 posts - 1 through 9 (of 9 total)
  • The forum ‘Video Output on RetroPie’ is closed to new topics and replies.