Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #3822

    When i try to launch a neogeo game (any) console shows a 1 sec message and then the all thing freezes with a white dot in the middle of the screen.

    I cant read the terminal msg cause its too fast.

    Please help


    aparently i do not have a gngeorc file..


    Here are some updates on this

    Retropie has 2 versions of gngeo (neogeo emulator).

    Disregard the older version (0.7), its too old and buggy.

    When using roms for the gngeo-pi-0-85 you need 3 steps.

    1 – You must put the bios files (extracted) in the rom folder and in the neogeobios folder (/home/pi/RetroPie/emulators/gngeo-pi-0.85/neogeobios/). You can find bios files ( and in google.

    2 – You also need file in the installdir/share/gngeo folder. Search google also for this file. The files inside this zip are .drv. You can only play roms that have the same name as these .drv files, e.g. (rom) and mslug2.drv (data). If the names of these files dont match the game will crash.

    3 – Also make sure the /home/pi/.gngeo/gngeorc file exists (this is the file you edit for configurations, joypad etc)

    I have alot of roms running from this link:

    Best of luck


    Hi im trying to get the gngeo0.85 to work but the rom loads but the screen is distorted and I have no sound.

    When I try and exit the game the raspberry pi freezes. Ive tried putting the file in the ‘share’ folder which located here I guess:


    but there is no neogeo folder. If I put the folder there what should it be named and does it need any underlying folders?

    furthermore I’ve tried finding the gngeo_data zip but no luck googling it.. first link in google I renamed an gngeo-0.8.1-cmv….rpm file into a :(


    Hey guys and gals

    I have spent 2 full days trying to get neo geo games to run and the furthest I got was by following this thread.

    Unfortunately I am still unable to get things happening.

    I have made a couple of assumptions and will try to explain in the hope that someone can please help me get neo geo games happening cause I’m starting to pull my hair out here and at 38 I don’t have much left – I really need to shoot some Metal Slugs to let off steam!

    STEP 1

    I had no neogeobios directory at /home/pi/RetroPie/emulators/gngeo-pi-0.85/ so so I ASSUME the folder needed to be created – correct?

    I am unzipping the BIOS files in Windows 7 using the default Windows unzip utility and then sftp’ing the files over using Filezilla – so when I unzip and the directories created are then called neogeo and uni-bios – are these the correct directory names because I notice that in the above how to it says unibios and not uni-bios which was the name of the original zip file I downloaded?

    So when I have the extracted directories inside these are:

    uni-bios directory content = uni-bios.rom


    neogeo directory = 000-lo.lo

    Is this what I require? Do I use all these files?

    Do I place the neogeo and uni-bios DIRECTORIES at /home/pi/RetroPie/emulators/gngeo-pi-0.85/neogeobios still assuming that I create a directory named
    neogeobios at /home/pi/RetroPie/emulators/gngeo-pi-0.85/ OR do I place ONLY the FILES within those directories at that location?

    STEP 2 – place extracted directory at path? Place content of extracted directory at path? Place at path?

    Also I ASSUME once again that FULL path = /home/pi/RetroPie/emulators/gngeo-pi-0.85/installdir/share/gngeo/ is this correct?

    STEP 3

    I have no gngeorc file at /home/pi/.gngeo/ – the .gngeo directory is empty so what do I do – create a new file using Filezilla? If so what content needs to be written to the file?

    I’m really sorry to have revived a thread that is a couple of months old and for asking so many questions but I’d like to get this working.

    I’ve been going round in circles on Google and at this forum, Git Hub and Raspberry Pi forums but I can’t see a full step by step guide on how
    to get this working.

    The best I’ve done is the good old dot in the centre of my monitor trick, a message from gngeo about can’t find file and press any key to exit or something
    to that degree and best of all the neo geo looked like it was loading at one stage but then froze.

    MEGA post I know but I wanted to be clear so unfortunately I couldn’t quite be concise- sorry all – please help me out here – killin me!


    in the es_systems.cfg uncomment the COMMAND line that has the pifba in it and comment out the origional COMMAND line. this will switch the emulator to the pifba one that seems to works better. however the roms are still hit and miss


    Thanks for the reply

    Could you possibly clarify my other questions by quoteing?

    Neo Geo emulation has been driving me seriously batty – i have atari 2600, nes, snes, psx, mastersystem and gba sorted but this just ain’t happening for me.

    Like I said could you please clarify the questions I have asked – trying to save as much confusion here as possible – cheers.

    (are you possibly saying that using the other emulator negates the need for the BIOS files? If not where is the placement, do I need both neogeo AND uni-bios and if so how and where are they placed, packed? unpacked? the files inside the unpacked directories only)

    Linux for lin00bix here!


    Alright so I’ve edited the lines as suggested in the es_systems.cfg file at /home/pi/.emulationstation – is this the file you refer to?

    If that is correct then what is the next step for me?


    all you need then is the bios file in the ROMs folder and, at least for me it works, it also works for fba. I know it can be frustrating but 99% of your answers are in the forum, took me a bit of time to find most of my answers but solutions are here… just a FYI dont bother with ps3 controllers, 360 wireless are much less of a headache ;)


    [quote=5504]just a FYI dont bother with ps3 controllers, 360 wireless are much less of a headache ;) [/quote]It’s just too bad that the Dpad is kind of crap compared to the one on the ps3 controller :/ I eventually got myself the silver special edition controller that is said to have a better Dpad. Still not as good as the ps3 one but it definitely works now, and as you say it’s easy to get it up and running.
    A tip. I’ve opened the wireless receiver and soldered the circuit board into the pi. Easy done, only 4 wires, and well worth the effort if you want less cables.


    i remaped the buttons and only use the analogs, i HATE the Dpads.. dont get me wrong, the PS3 pads are great, but a bit@h to set up, once you do get them, its cool they rumble leds work etc as should, but was a real pain to get them to that state, the 360s were a breeze, im talking about the wireless versions, as i didnt want wired, although those are the easiest….


    Thanks for posting back – I have progress!

    After changing the es_systems config file to use piFBA I have placed the zipped neogeo BIOS directory inside /home/pi/RetroPie/roms/fba along with

    If I select kof98 from the menu it loads into the checker board screen, I then select the Start button (on my single generic RetroLink SNES controller) and get the color adjustment screen – I then hit the start button again and get to the I/O screen.

    I guess this is why you guys are talking about best controller cause from there I can’t figure out what I need to do to get the game running.

    I have absolutely no idea what I’m doing with controller configuration files and was lucky enough to be directed to a download of a dgenrc configuration file and also a retroarcg.cfg file which is good for atari2600, nes, snes, psx, mastersystem and gba. These are the ONLY controller config files I have touched.

    I have attached the above mentioned config files (EDIT- MMM – no config file uploads permitted :(-

    could someone tell me where I need to go from here to get neogeo happening please – what do I need to do at the I/O screen or elsewhere to get this working?

    (stay tuned for questions about n64 controller configuration – ha :)



    OK so from the same source I gots me the I gots me a copy of mslug (thought I’d try another game for s***ts and giggles.

    This time it’s a different problem – I have all the audio and I can hear my weapons being fired if I furiously hit the buttons but all I have in relation to OSD after apparently inserting my coin is a sky blue background, level and credit text at the bottom of the screen and the arms/bomb count and insert coin for second player flashing at me at top of screen – sheesh.

    So is this like so many people say that it is a matter of finding the right BIOS and the right ROM and then you MIGHT get results or am I having yet another issue here?

    Freakin hell – there has to be an easier way – take this as a joke cause it is one but for bejesus’es sake I’m just about ready to do some real shooting if this don’t co-operate shortly and I mean pronto!!!!


    Triple post hog here – apologies.

    But s*****t yeeeeeahhhhh – SUCCESS!!!!!!

    Thanks for the help and steering me in the right direction all – much appreciated.

    I mentioned it at another post I have made here at this forum but I’m gonna say it again – I think I just made another Splashscreen in my pan…. nah false alarm again.

    RetroPie and Rpi rocks!!!!!!!!! :) :) :)

Viewing 14 posts - 1 through 14 (of 14 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.