Homepage Forums RetroPie Project New to RetroPie? Start Here! N64 controller issue

Viewing 1 post (of 1 total)
  • Author
  • #120053

    So I just recently bought the RP2 and installed RetroPie on it. The first time I installed Retropie on my RP1 I had some issues with the controller. I use a third party xbox 360 wireless adapter off from ebay with my wireless controllers. The adapter was plug and play and I set up the controllers with the gui setting in RetroPie. I did however have to change the joypad driver to sdl in the cfg file in Retro to get it working.

    This time, I have done everything the same way, except it doesn’t work for the N64 emulator. Before when I launched a game I got a message saying “Xbox 360 accessory wireless controller configured on port 0(sdl)” or something like that. Now when I launch a game, I get the same message, except it says (userdriver) instead of sdl. But everything seems to work fine though, all my hotkeys and things work. Except when it comes to the N64 emulator. The controller works just fine except the hotkeys, so I cannot save or load any game. I’ve tried setting the controller explicity in the emulators cfg file but it won’t make a difference. All the other emulators has set the joypad driver to “unused”.I do not get any message saying my controller is configured in the N64 emulator like I do for all the other emulators, so there is clearly some issue with setting the controller. I might add that pressing “select”+”start” seem to work though to exit the emulator.

    On all the emulators I get a message saying my 360 controller has been configured with userdriver except on the N64 emulator. I can play the N64 games with no problems, it’s just my hotkeys for save and load that doesn’t work, exit the emulator works just fine. How do I fix this?

    I tried all the emulators available and discovered something odd. When I use the IR-mupen64plus emulator, I can save and load and I do get the message saying the controller is configured. But if I try any other emulator, let’s say mupen64plus-gles2rice, I don’t get any message that it has been configred. So U could go with only using the IR-mupen64plus, but it dosn’t always work that good.

    Weird, I’ve never had this issue on the RP1 before.

Viewing 1 post (of 1 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.