Viewing 1 post (of 1 total)
  • Author
  • xvyion
    Post count: 1

    My hope is that I can eventually play Legend of Zelda: Ocarina of Time. However, right now it is unplayable and I’m hoping the internet can help. I have tried two ways to get this working, one through RetroArch as the latest RetroPie comes configured to do natively. The second with just mupen64plus without retroarch on top. I’ve had different problems with both. And I’ve been Googling my problems for a week now with no luck figuring these things out. As a note, I have a retrolink USB N64 controller.

    First, Mupen. This one is the simpler of the two to describe. My only real issue is that after playing for about 10 minutes, my controller becomes unresponsive. This happens with any N64 game I’ve tried, not just OoT. That makes it unplayable. I’m also having an issue saving (save states not working), but I haven’t really looked into that problem yet because of the controller issue. I haven’t found any reason for the controller issue to be happening yet, and the controller works just fine with any other emulator (played Doom for an hour without issues as well as other games). Oh, and the keyboard is fine and I can exit the game using ESC no worries. Then when EmulationStation loads up again the controller is still fine.

    Second, RetroArch. The biggest problem I’m having is that the default controller configuration seems to be wrong. Now, I know that Mupen has it’s own configuration file. That isn’t the problem. Mupen’s controls are configured fine (I know this because as I described above I don’t have this issue when running with just Mupen). It even loads up and states the controller (Generic USB Joystick) that Mupen is using just like it does when I run the game with only Mupen. However, with RetroArch on top when I get to the menu the start button works correctly as does the joystick, but the left C button acts like it is the A button and nothing else has any effect. Also, the keyboard stops working correctly too. The enter button works as if it were the A button on the controller and that is all. ESC no longer exits the game. I’ve been able to reconfigure the controller with retroarch-joyconfig, but I haven’t found a configuration that actually makes the game playable yet.

    Additionally for RetroArch, the graphics and sound are messed up. I can’t describe it better than that. Certain textures are a bit off and certain layers (health bar) don’t seem to be displayed at all. The sound crackles a bit at times though I haven’t gotten passed starting a new game thanks to the completely useless controller settings. This is all using the same configuration (for Mupen) as with just Mupen above (which doesn’t have any noticeable video or sound issues).

    If anyone has any thoughts on either of these directions I’d be grateful. Ideally I’d like to figure out the Mupen only approach since it seems the least buggy so far, but I’d be happy with either.

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.