Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • goodjaerb
    Participant
    Post count: 5

    I’m pretty sure this is brought up a lot but everything I’ve yet found doesn’t work.

    First thing is I am running on an Ubuntu 15.10 PC set up per the wiki.

    My mupen64plus.cfg claims I should be able to hit Back and Start J1B8/J1B9 to quit the emulator, but that doesn’t work, and all mention of it I can find online says mupen doesn’t support hotkeys like that.

    So I edit it to be just the back button J1B8 (which corresponds to jstest and the default mupen settings) and it still doesn’t exit. However I believe this is because even though I edit the file, when I run emulationstation / mupen64plus, something removes/rewrites/replaces the cfg because not only does it not work but when I check the file after it is reset to J1B8/J1B9, which I know doesn’t work.

    So I tried what I did with my reicast config and made it non-deletable/editable. Well when I run mupen64plus straight out of /opt/retropie/emulators/mupen64plus/bin it throws an error if it can’t alter the file and uses default settings anyway. So again it doesn’t use my cfg edits.

    I don’t understand if it’s suggested to edit these files why would emulationstation/mupen (and reicast fwiw) edit and replace them anyway. Is it something strange because I’m using Ubuntu instead?

    Also I would love to just use lr-mupen64plus because the retroarch configuration lets me exit, but the games don’t display right AT ALL. Maybe if someone can tell me why or how to fix lr-mupen64plus I’ll be ok.

    Thank you and I’m sorry it’s so much talking.

    jaspreet97
    Participant
    Post count: 9

    Not a solution but I have the exact same issue but with me sometimes the Exit combo does work and lets me leave the emulator Sometimes it doesn’t. Setting a single key doesn’t work either and I see the same behavior in all three non LR emulators. the LR one is funky atleast in the game menus

    g0nz0uk
    Participant
    Post count: 310

    You have got further than me. Since Retropie 3.4 and above I can’t get my 2 wireless xboxs to work at all on the N64, all other emulators are good, don’t really want to roll back.

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.