Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • mattmartinolc
    Participant
    Post count: 14

    Stumbled on a YouTube vid of a guy running N64 pretty smooth on his Pi using Mupen64 in a GUI…

    https://www.youtube.com/watch?v=7zkUnkgIDJE

    Just wondering if anyone has been able to get their Mupen64 working with RetroPie this smoothly, and what the settings are for achieving this?

    whise
    Participant
    Post count: 71

    my best guess is a high overclock

    kitchuk
    Participant
    Post count: 207

    It’s still a quire choppy fps wise. Also the sound still get crackles due to buffer underruns. Try over clocking your pi and that should increase performance. Also run in console rather that x windows.

    mattmartinolc
    Participant
    Post count: 14

    My overclock is quite high. I have a 5.1v 2.1amp power supply feeding my Pi, the operating system running on a USB stick and also have heatsinks and a fan cooling it. And gpu_mem_512=384

    Should I change the memory split? I saw most have it at 384 so I did too.

    arm_freq=1130
    core_freq=560
    h264_freq=360
    isp_freq=0
    v3d_freq=360
    sdram_freq=675
    over_voltage_sdram=6
    over_voltage=8
    temp_limit=80
    avoid_pwm_pll=1

    mattmartinolc
    Participant
    Post count: 14

    I read into things a bit more and found out the guy that put up the video is using a custom build of Mupen64 http://www.raspberrypi.org/phpBB3/viewtopic.php?f=78&t=58395.

    They claim to have certain games like Mario64, mario kart, turok, starfox etc all running smoothly.

    There are posts in there about getting that version of Mupen to launch from RetroPie as well.

    *EDIT: The github page for their build is here https://github.com/ricrpi/mupen64plus-rpi

    whise
    Participant
    Post count: 71

    My overclocking settings are much lower than yours, and I think my mario 64 runs pretty good.

    Im not shure if its that smooth though, but I play it without noticing any lag or slowness.

    I cant say that on other n64 games unfortunatly.

    crystalj
    Participant
    Post count: 14

    Mario 64 is about the only game I’ve had any luck running so far. I run at arm_freq=1000 and sdram_freq=500 and it plays quite smoothly, including sound. No luck with other games though.
    Maybe make sure your power supply is enough? I am using this one, which came recommended by other pi users.

    whise
    Participant
    Post count: 71

    mupen64plus-pi just had some updates, I think ill try compiling the new version.

    whise
    Participant
    Post count: 71

    Here is some points:
    Original http://www.raspberrypi.org/phpBB3/viewtopic.php?f=78&t=58395&start=150

    I think RetroPie pulls the master branch from the repository. The ric_dev branch is usually slightly faster but more likely to have errors.

    To get the best performance you should do the following:
    1. Overclock the Pi to its maximum stable speed (use ‘sudo raspi-config’ )
    2. Run mupen64plus using sudo/root so that it can change its scheduler policy to ‘hog’ the CPU
    3. Use 128Mb GPU/CPU memory split. The current code doesn’t force the kernel to keep pages in ram so if the split is too high, then pages will be swapped and slow emulation down. (Fix coming soon)
    4. Run mupen64plus without the desktop (use Ctrl+Alt+F1; [log in]; sudo telinit 2)
    5. The video-gles2n64 plugin is the fastest so use it if it works with the ROM you want to play.
    6. Modify mupen64plus.cfg as detailed in other posts and in the repo wiki (Although it needs more detail)

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.