Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • tronads
    Post count: 3

    Hello folks.
    This is my first build of this marvelous project, and it went pretty well really.
    I have mame4All and snes roms loaded up, figured out the scraper etc, so its all running quite nicely.
    Its on an original Raspberry Pi that has sat gathering dust for about 3 years, but I am so impressed with this front end, I plan to remove the PC from one of my arcade cabs and replace it with a new Pi2.

    Unfortunately I am experiencing a problem I cant seem to resolve.

    When I start Mame up, on any game, the left input is permanantly stuck. So if I start for example Galaga, as soon as the game starts, the ship moves all the way to the left side and the only thing you can do is hold right down, and it freezes its movement, but as soon as you release it, it resumes left again.

    I have not put it in the cab, so I am using a simple keyboard, and no joystick.

    I do not get the same problem in the SNES games, they work fine.

    If I press tab to bring up the Mame menu, I cannot do anything on it because of the constant left cycling through the menu.

    Also, I have tried unplugging the keyboard as soon as I start a game and it still just goes left, so its not the keyboard causing the issue.

    Anyone any ideas what I can do to resolve this ?


    Post count: 3

    As an update to this, my Pi2 arrived, and I did a complete new build, and did the initial setup in my cab.

    Unfortunately the exact same thing is happening, the input is stuck on a constant left.

    Has anyone else had this and managed to resolve it ?

    Post count: 3

    I have now solved this, and thought I would put the rather simple solution in case it helps anyone else.

    I discovered that it was not always left that was stuck down, sometimes it was up. Given that I had removed the keyboard and it was still doing it, I figured it must be thinking there was a joystick plugged in and was getting a bit mixed up, so I plugged in an old joystick, and on the next run, everything was fine. Removed joystick and it went bad again, so confirmed this was the issue.
    So, with the joystick plugged in, I went into the mame menu, general inputs, and went through removing any reference to a joystick input, reverting them just to keys.
    Removed joystick, and now all is well.

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.