Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • Roo
    Participant
    Post count: 211

    Using 2.6 SD card image, with libretro gba core – in game saves don’t seem to work at all for many games.

    *.sav files are being created in the /home/pi/RetroPie/roms/gba-gpsp-libretro directory – even when the game gives an error saying it couldn’t save.

    Is it just me or can anyone else confirm this? (by the way, I can save state no problem in every game I’ve tried)

    For example:

    Advance Wars:
    Seems to save OK but when I exit and restart the game, it won’t load the save and starts from the beginning (input your name)

    Advance Wars 2:
    Same as 1 – seems to save OK but when I exit and restart the game, it won’t load the save (no option to continue, have to start a new campaign)

    Golden Sun:
    When attempting to save, I get the message “Unable to detect backup memory.”

    Mario vs. Donkey Kong:
    When launching the game, I get the message “ERROR Flash hardware could not be detected. Saving is disabled.”

    Wario Land 4:
    Saving works normally

    Zelda Minish Cap:
    Saving works normally

    ShadowKnight
    Participant
    Post count: 14

    Yeah, I have a similar problem with GBA. When I played Advance Wars and decided to save a state, it worked sometimes. To make it work for sure, every time I save a state, I save it two or three times more.

    Haven’t tried Golden Sun yet. Every other emulator seems to work fine for me though…

    vmax192
    Participant
    Post count: 5

    Hello,

    i can confirm there is a problem in some games with gba libretro, i’m running 3.0 beta2 and my advance wars saves that was working just fine with previous retropie versions won’t load anymore.

    is somebody have a solution to this ?

    edit: i tried golden sun and it works perfectly for me, for now i just have problem with advance wars

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.