Viewing 1 post (of 1 total)
  • Author
  • JayMad
    Post count: 1

    Good morging everybody!

    First of all: Thanks for the project, which brings my childhood back ;)

    I’d like to play the game “Escape from the planet of robot monsters” on MAME. The game loads, I can put some coins in and start. But when the first level appears, no player is shown and I cannot control anything but the MAME menu.

    My first thought was, that I had a bad romfile. So I tried some roms from different sources. All with the same result.

    My last test was to run the game directly from the command line. I hoped, that there would be a “verbose” option to get some issues printed on the console. But there isn’t. But if I use the option “-nocyclonecore”, the player of the game appears and I can “control” it. But the control is some kind of strange:
    – When I use my arcade stick, I can jump, shoot, duck and walk upwards. The down, left and right axis does not seem to be recognized
    – When I configure the player 1 input back to keyboard, I can use all axis and buttons, but when I release the axis the player keeps walking forever.

    All other MAME games run fine.

    I also tried the same rom on the mame4all emulator on my android phone, which runs very smooth.

    Does anybody has a hint for me?

    My Setup:
    – RPi2 (but also tested with a RPi 1 B version with same result)
    – Installed RetroPie using basic raspbian image and Retropie-Setup (tried build from source and binary)
    – SNES GPIO-Adapter (not on RPi1)
    – Custom kernel (caused by the axis-auto-fire problem with xin-mo controller; not on RPi1)

    Greetings from germany,

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.