Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • pixelbrei
    Participant
    Post count: 4

    hey there :)

    i tried for countless hours to get the sound samples for old mame games to work without any success. any help would be greatly appreciated.

    what have i done so far … retropie in the latest official version is running smooth. the mame default emulator is set to mame4all. im pretty sure, that i have the right rom set and the games are running more or less all. what i found by sorting out /reviewing the games is, that the sound on the older mame games is not working. for example the 2 games i try in specific are: berzerk and space invaders.

    it took a while for me to realize, that for the first steps i need the correct sound samples. soooo i took them from the mame4all readme files which should be the right one do not post links to romsites and copied them over (unzipped the big file i just downloaded) to the corresponding folder from the mame.cfg file. but as you might allready thought .. without any luck … i also changed the path and copied them over to an alternative path .. but also without any luck. the samples name and the rom name match also …

    #samplepath=/home/pi/RetroPie/roms/mame-mame4all/samples
    samplepath=/opt/retropie/emulators/mame4all/samples/

    am i missing something essential ?

    thx in advance :)

    pixelbrei
    Participant
    Post count: 4

    okay … after a bit of testing and putting the roms in different folders and therefore different emulators as well, i found out, that the samples (at least for my test rom : berzerk) are only working when i put the roms in the folder for “mame-advmame”.

    here i create two subfolders for “artwork” and “samples” and (atleast for berzerk) the 0.375 roms and samples and stuff, seem to work.

    i did not change any other configs (no mame conf or pathschanges which seem to only be relevant for the libretro based mame stuff).

    tldr … assuming i did not made any major faults, soundsamples for mame only work in the advance mame right now … but .. i loove mame4all way more then advmame (shaders/overlays for advmame anyone ??) :( :)

    by the way .. can anyone guide me on how to setup hotkeys for advance mame ? ;)

    VGMonkey
    Participant
    Post count: 10

    I’m having issues with samples in lr-imame4all. The samples work in mame4all but I can’t use the controller to play,
    The samples don’t work in lr-imame4all but the controller works fine.
    I’m on a pi1 b so the other mames are not an option.

    petrockblog
    Keymaster
    Post count: 1828

    samples are not supported – I have submitted a pull request upstream to enable samples (by putting them in a samples folder in the same dir as the rom)

    VGMonkey
    Participant
    Post count: 10

    Thank you, I never know if its my lack of knowledge or the fact that the emulators are still being worked on and updated.

    petrockblog
    Keymaster
    Post count: 1828

    I had no idea about this one either – I had to look at the code. I have just updated updated binaries, so if you reinstall lr-imame4all from binary from retropie-setup menu 5, you should be able to get samples working

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.