Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • alienhead
    Participant
    Post count: 4

    Hi!
    I’m using retropie with my saitek gamepad. It works great with (s)nes, gameboy, megadrive… Now I want to use it also with MAME, but it seems not to be recognized. I read that I need to press “Tab” to configure the gamepad, but I don’t own a usb keyboard. Is there a way via ssh and a config file to use my gamepad?
    thanks in advance

    herbfargus
    Member
    Post count: 1858

    I don’t know of any way to change those configs but you could try switching to lr-mame4all for the default emulator- that uses retroarch configs

    alienhead
    Participant
    Post count: 4

    @herbfargus: thanks. I tried lr-mame4all but had some issues with various roms. with mame4all all my roms loaded without problems but I can’t control them. :-/

    leiptrstormr
    Participant
    Post count: 5

    [quote=101300]I don’t know of any way to change those configs but you could try switching to lr-mame4all for the default emulator- that uses retroarch configs
    [/quote]

    The global retroarch input configs use select as coin insert on Final Burn Alpha, but not in advance mame or mame4all. Without coin insert, everything else is useless. I can’t even use the start + select hotkeys to exit the game. From what I understand, configs are in /opt/retropie/configs with /all being global. My retroarch.cfg inputs look like this and I am using RPi2 V3 beta4 image.

    Edit: Ok so I figured out default settings on RPi2 V3 beta4 doesn’t use lib retro mame4all.
    /opt/retropie/configs/mame-mame4all/emulators.cfg
    Change to default=”lr-imame4all”

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.