Tagged: 

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • minos
    Participant
    Post count: 9

    Hello, i’m Pedro, a noob in linux, have installed the retropie within the PiPplware 2.0 (a portuguese distro based in Raspbian (2014-01-07) [http://pplware.sapo.pt/linux/pipplware-2-0-descarregue-ja-a-versao-final/]). It cames with pifba for MAME games.
    My problem is, when i choose a game from MAME emulation station (all roms are from 037b5 romset, and are into the \retropie\roms\mame directory) it try do load, apears on the tv a fast scroll of white letters, then cames back to the emulestation MAME screen with the list of games. It does this in EVERY single game… something wrong, cause at least one should be ok. Also checked the roms name with the gamelist.txt. Please help me! I tried to find something in the forum, but got lost in translation…!

    Thanks in advance.
    Pedro

    minos
    Participant
    Post count: 9

    Ok, downloaded some mame BIOS and put them in roms directory. IT’S OK NOW, almost all games load.

    Then realized that the resolution using pifba was poor, so changed in the es_config to use MAME4ALL. Perfect the roms loaded and with much better resolution, but lost the usage of the usb controller that was using with pifba. Tried to configure it again in “input configuration” on emulationstation and it doesn’t work either. Seems that the path to joypad configuration is different between PIFBA and MAME4ALL. Any thoughts??

    Please help.

    Thanks in advance.
    Pedro

    chris2k
    Participant
    Post count: 3

    Hi,

    Plug in a keyboard and press the “TAB” Key while you’re in Mame4all. A menu will open, where you can configure all your buttons.

    The button-config file is in binary format, so editing it via command line is no possible (or at least so it seems to me..)

    Btw, which BIOS (file names, so i can google them) have you used? i have a similar problem, for me ~40% of my roms are working.

    minos
    Participant
    Post count: 9

    Thanks for the response, but when press tab in the menu that open it cannot accept the joypad buttons, it seems tha it doesn’t exists… Still needing help…

    The mame BIOS are MAMEBIOS from emuparadise.me and MAME BIOS pack from planetemu.net

    chris2k
    Participant
    Post count: 3

    Thx!

    You have to start any mame game, and press TAB while you are in the game!

    Then the menu should appear! Have you tried this WHILE IN GAME? Doesn’t work when you are in emulationstation.

    minos
    Participant
    Post count: 9

    Thanks, have tried this solution early but didn’t realize that had to hold for a few seconds the buttons on the commanda pad to be memorized in the MAME menu. Many thanks!! All working.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.