Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • kraken0667
    Participant
    Post count: 38

    Hello

    For easy ROM access I use a USB flash drive as path/directory to all my games.

    I recently bought a USB sound card from ADA to get decent sound, and everything works great, exept for lauching MAME games. The ROMs are detected in Retropie menu, but they dont launch. When I try, I just get back to menu. All other emulators Ive tried still work. When I unplug the USB sound card and reboot, MAME ROMs load perfect again. So, I guess MAME in particular does not like the sound card. Can this be fixed somehow? I still want to have ROMs loaded from an external USB flash drive.

    kraken0667
    Participant
    Post count: 38

    Bump!

    Update: I moved my MAME ROMs to the SD instead and loaded from there, same issue. So this has nothing to do with loading ROMs from USB. It just seem the USB sound card / audio adapter interfere with mame4all somehow.

    So, when I try to launch a MAME ROM with USB sound card connected, I just get thrown back to emulationstation menu(No error messages, no missing file message etc)

    When I launch a MAME ROM with the USB sound card disconnected, it load perfectly without issues.

    Any help would be much appreciated!

    kraken0667
    Participant
    Post count: 38

    So I tried this link:

    and now some MAME ROMs actually work, most still don’t though.

    When trying to launch a game, I get this message flickering by real quick:
    “lv10 Error saving gamelist.xml to “”/media/usb0/games/mame-mame4all/gamelist.xml”

    Is this the issue?

    Floob
    Member
    Post count: 1629

    Which arcade emulator (version) are you using?
    Have you validated the romset?
    https://github.com/RetroPie/RetroPie-Setup/wiki/Managing-ROMs

    kraken0667
    Participant
    Post count: 38

    Im running mame4all with the 037b05 ROM set.

    They all work with the USB-sound card disconnected

    But as soon as I connect it, MAME games wont launch.

    Very strange…

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.