Tagged: , , ,

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
  • helpman
    Post count: 37

    Hi there!
    Gngeopi is producing me nightmares right now…
    tried different romsets, even tried clrmame with the dat master files to make sure it’s ok. checked neogeo.zip so all needed files were there…

    List of games show on the emulation station shell… click one, just a couple lines of text, no errors at all, then goes back to the game selection screen. nothing!

    not knowing if I was doing something wrong or not, decided to install FBA. same happened.

    now I don’t know how to get rid of the unused emulator (gngeopi or lr-fba) just to make sure there isn’t some kind of weird compatibility problem reading roms on neogeofolder as both emulators are reading the same rom folder.

    so… how can I remove the unneeded emulators? or how can I choose which one will be used for neogeo? why they refuse to work? aaaaaargh! please help me!

    BTW, I have no idea about linux, I’m just following tutorials found here and there.

    Post count: 1858


    Should be no need for gngeopi, lr-fba works just fine (provided you have the correct romsets and bios)

    Post count: 571

    also those rom sets & bios are very easily available!

    Post count: 37

    I tried lr-fba with a neogeo full romset. It shows no error, but goes back to game list anyway

    Post count: 571
    Post count: 37

    I have a neogeo.zip pobre 1.5mb, that includes all bios, but I’ll check anyway. Bios for neogeo must stay on the neogeo rom folder right?

    Post count: 1629

    @helpman – Please note it must match the exact version that is mentioned here:

    So lr-fba must be fba

    Yes, bios for neogeo seems to need to be in the roms folder.

    Post count: 97

    I tried downloading Metal Slug from REMOVED do not post romsites! and switching it for the working version of M. Slug that I have on my RetroPie. It didn’t work. So I’m convinced that you’ve got one of those infamous ROM incompatibility issues.

    I’m lucky enough to own a ROM set that I downloaded years ago. That GeoGeo and Mame set works w/ the versions of the emulators in RetroPie.

    I guess that you should ask help on converting your ROM set to and older version and check that the BIOS file you have works too. I don’t know if the BIOS Zip file needs to be of a certain version too. In the links that the others gave you above there appears to be a method of converting ROMs if I’m not mistaken.

    Good luck in converting!

    P.S. I use GnGeo-Pi.

    Post count: 1858
    Post count: 37

    I tried clrmame over my romset to build a compatible set, everything on clrmame is ok, but fba just refuses to work. anyway, some roms finally work on gngeopi, but most of them just go back to game selection menu without any error at all. it’s weird but at least bios files seems to be working

    Post count: 97

    [@mod: sorry for mentioning a specific ROM site, I thought that it would be okay because I did not post the exact internet address of the site]

    If some games do work in GnGEo-Pi then the BIOS file you have and the configuration of GnGeo-Pi is good. The only thing that’s probably wrong is that CrlMame did not convert all ROM’s that you have into something that can actually be used by the GnGeo-Pi version that RetroPie uses. Since I do not know where to upload the ROM’s that I have, and given that it is most definitely forbidden to even discuss this on this forum, I guess that you’ll have to jump through some pretty difficult hoops to get Neo Geo ROM’s from romset 0.138 (see this link for info) then from the internet (torrent?).

    The link that I mentioned says that GnGeo-Pi in RetroPie uses romset 0.138, piFBA uses romset 0.114 and that lr-FBA uses romset 0.154. That means that if a ROM works in GnGeo-Pi (in RetroPie) then it wil definitely not work in FBA because they need different romset versions.

    Good luck! :)

    Post count: 1629

    Here is a brief overview of gngeo config if it helps

    Post count: 37

    as for fba you can use neogeo folder or use on its own fba folder I’ll keep the ones working with neogeopi and try to make fba work. I do not have those romsets, but I’ll try with clrmame to build them using mame 0.37b5, 139, 167 and the neogeo 1.1 (whichever version is that) that seems to work at least partially with gngeopi… wish me luck :)

    gngeopi looks nice, but it won’t exit with both select and start pressed, and it doesn’t look nice to enter a menu then select quit…

    btw, it would be nice to have a mame based emu that could run all mame games and neogeo too… pimame4all works nice, but doesn’t support all neogeo titles… any suggestion? I’m using a raspberry pi 2

    Post count: 97

    About GnGeo-Pi and its controller setup. You can choose almost any button to activate the menu and set certain buttons on your Gamepad to be the “yes” and “no” to choose options in the menu (like Exit). This is my from my personal tips and hints text file, hope it helps:

    About GNGeo-Pi:
    Emulator used: GnGeo-Pi. See https://github.com/RetroPie/RetroPie-Setup/wiki/neo-geo. Once you’ve started GnGeo-Pi at least once a file called gngeorc will be created here:


    For more info about the config file, see: https://github.com/ssilverm/PiMAME/blob/master/.gngeo/gngeorc.

    Example, my /home/pi/.gngeo/gngeorc file:

    # Meaning of the code:
    # Kxxx : keyboad key number xxx
    # JxByy : Joystick number x Button
    # JxAyy : Joystick number x Axe yy (use a lowercase ‘a’ if you need to invert the axis)
    # JxHyy : Joystick number x Hat yy
    p1control A=J0B0,B=J0B1,C=J0B2,D=J0B3,START=J0B9,COIN=J0B8,UP=J0a1,DOWN=J0a1,LEFT=J0A0,RIGHT=J0A0,MENU=J0B7
    # system type? arcade or home
    # ‘home’ doesn’t seem to work…
    # country?
    # japan, usa, europe
    rompath /home/pi/RetroPie/roms/neogeo

    About Joysticks:
    Config files -> Joystick configuration is vague and complex. The following config files are but a few:

    [1] /opt/retropie/configs/all/retroarch-joypads/ThrustmasterTMiniWireless.cfg
    [2] /opt/retropie/configs/all/retroarch.cfg
    [3] /opt/retropie/configs/nes/retroarch.cfg (EXAMPLE)
    ([4] /home/pi/.emulationstation/es_input.cfg )

    Button codes -> Find the numbers for the various buttons on your particular gamepad in [1]. File [4] seems to be an over ride. Example of gamepad entry fot the Nintendo NES in file [3] [https://github.com/RetroPie/RetroPie-Setup/wiki/RetroArch-Configuration]:

    input_player1_a_btn = 0
    input_player1_b_btn = 1
    input_player1_y_btn = 2
    input_player1_x_btn = 3
    input_player1_start_btn =
    input_player1_select_btn =
    input_player1_l_btn =
    input_player1_r_btn =
    input_player1_left_btn =
    input_player1_right_btn =
    input_player1_up_btn =
    input_player1_down_btn =
    input_player1_l2_btn =
    input_player1_r2_btn =
    input_player1_l3_btn =
    input_player1_r3_btn =

    Test joystick/determine numbers of your buttons etc. [https://github.com/RetroPie/RetroPie-Setup/wiki/RetroArch-Configuration]:

    jstest /dev/input/js0

    Setup controller -> from command line:

    sudo ~/RetroPie-Setup/retropie_setup.sh

    and choose “Register Retroachch controller”.

    Post count: 97

    [quote=113833]Here is a brief overview of gngeo config if it helps

    <span class=”embed-youtube” style=”text-align:center; display: block;”>


    That 35 min. video was very helpful for me when I set up my Pi for the Neo Geo. But it does not explain how to convert ROMs from one romset version to another (nor where to get the “old” romsets…).

    Post count: 1629

    To verify/convert romsets the guide, including a video, is here:

    Yes, you cannot request where to find romsets here.

    Post count: 37

    ok, so FINALLY, I made lr-fba WORK! woohooo! (GNGEO was still producing some errors and decided to try fba as suggested by other users)
    I guess it supports more games that gngeopi or whatever, just though it would be easier to use the retroarch config…

    so I tried running a game, and of course the button I use for credits on mame just won’t work… opened retroarch.cfg file for this emulator (neogeo) and it was empty, as it loads the default ALL cfg.

    so I opened the ALL systems retroarch.cfg and it was a mess. I couldn’t find a “coin” button there, nor how to link each control to my joysticks…

    This is the gngeopi cfg for both joysticks (about coin, only player 1 has that button (J0B13), as I only use 1 coin button, player 2 has a different one to avoid adding 2 coins each time I pressed it)
    menu player 1 (J0B8) is “select” and menu player 2 (J0B9) is “start” buttons.

    p1control A=J0B0,B=J0B1,C=J0B2,D=J0B3,START=J0B7,COIN=J0B13,UP=J0a1,DOWN=J0a1,LEFT=J0A0,RIGHT=J0A0,MENU=J0B8
    p2control A=J1B0,B=J1B1,C=J1B2,D=J1B3,START=J1B7,COIN=J1B13,UP=J1a1,DOWN=J1a1,LEFT=J1A0,RIGHT=J1A0,MENU=J0B9

    can anybody help me to make that work on retroarch?

    as far as I tested, select works as coin, start as 1player start.
    I need to keep select and start as they are, on the same buttons (J0B8, J0B9) AND also:
    J0B7 – player 1 start
    J1B7 – player 2 start
    J0B13 – coin

    is that possible?

    Post count: 37

    ok, forgive me :D despite the fear of damaging something beyond repair, I just tried my luck and remapped the buttons :D

    looks like select+start combo works even if you remap them to other buttons, so I’m really happy now. thank you guys, you’re great :D

    Post count: 37

    ooook NOT solved.

    I edited the file retroarch.cfg on /opt/retropie/configs/neogeo/ to look like this

    # Settings made here will only override settings in the global retroarch.cfg if placed above the #include line

    input_remapping_directory = /opt/retropie/configs/neogeo/

    input_player1_joypad_index = 0
    input_player1_b_btn = 0
    input_player1_a_btn = 1
    input_player1_y_btn = 2
    input_player1_x_btn = 3
    input_player1_start_btn = 7
    input_player1_select_btn = 13
    input_player2_joypad_index = 1
    input_player2_b_btn = 0
    input_player2_a_btn = 1
    input_player2_y_btn = 2
    input_player2_x_btn = 3
    input_player2_start_btn = 7
    input_player2_select_btn = 13

    #include "/opt/retropie/configs/all/retroarch.cfg"[/quote]

    and saved it.
    tried a game, and everything was running GREAT.
    then I exit the game, load it again… and nothing works.
    checking the cfg file, it looks like it’s a copy of the file on ALL folder.

    what happened? how can I keep the remapped file?

    [quote]core_options_path = "/opt/retropie/configs/all/retroarch-core-options.cfg"
    system_directory = "~/RetroPie/BIOS"
    assets_directory = "/opt/retropie/emulators/retroarch/assets"
    config_save_on_exit = "true"
    video_threaded = "true"
    video_smooth = "true"
    video_aspect_ratio_auto = "true"
    video_shader_enable = "true"
    video_shader_dir = "/opt/retropie/emulators/retroarch/shader/"
    video_font_size = "12.000000"
    overlay_directory = "/opt/retropie/emulators/retroarch/overlays"
    input_autodetect_enable = "true"
    joypad_autoconfig_dir = "/opt/retropie/configs/all/retroarch-joypads/"
    input_player1_a = "x"
    input_player1_b = "z"
    input_player1_y = "a"
    input_player1_x = "s"
    input_player1_start = "enter"
    input_player1_select = "rshift"
    input_player1_l = "q"
    input_player1_r = "w"
    input_player1_left = "left"
    input_player1_right = "right"
    input_player1_up = "up"
    input_player1_down = "down"
    input_exit_emulator = "escape"
    input_shader_next = "m"
    input_shader_prev = "n"
    input_rewind = "r"
    rewind_enable = "false"
    rewind_buffer_size = "10"
    rewind_granularity = "2"
    video_gpu_screenshot = "true"

    blahblahblah long file here you get the idea


    Post count: 37

    ok, solved, there was an option on retroarch to save setups on exit or something like that which was causing that file overwrite :?

Viewing 20 posts - 1 through 20 (of 20 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.