Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • kapteinknutsen
    Post count: 4


    I’m new to RetroPie, but have played with it for a couple of weeks now, trying to learn it (and linux) through videos and the wiki. Great documentation all around!

    There is one issue I have not been able to solve, which is that lr-mame2003 doesn’t seem to find any roms at all. I read some good stuff about mame2003, and would love to have it work. I have copied the roms into the roms/Arcade folder, and also into the roms/mame-libretro folder (just to be sure). The rom files have been built using clrmame, and have been reported to be OK. I’ve looked into the zips too, and all files are present. EmulationStation sees the roms fine, but trying to run any rom in lr-mame2003 just bounces back to ES. I’ve tried around 20 now. The runcommand.log report all the files are not found, which is weird since they’re all there in the .zip and the most compatible games run fine in lr-FBA and lr-mame4all.

    I am wondering if this could be a paths issue with lr-mame2003? Is there somewhere I can check or edit where this libretro emu looks for ROM files?

    I’m running RetroPie 3.6 on Pi3. Almost vanilla install, only added Daphne.

    Post count: 4

    I just realized I can do a verbose output from RetroArch, here’s the output I get trying to run Alien Syndrome:

    RetroArch [INFO] :: === Build =======================================RetroArch [INFO] :: [CPUID]: Features:
    Built: Feb 21 2016
    RetroArch [INFO] :: Version: 1.3.0
    RetroArch [INFO] :: Git: ccb3f73
    RetroArch [INFO] :: =================================================
    RetroArch [INFO] :: [CPUID]: Features:
    RetroArch [INFO] :: Looking for config in: "/root/.config/retroarch/retroarch.cfg".
    RetroArch [WARN] :: screenshot_directory is not an existing directory, ignoring ...
    RetroArch [WARN] :: SYSTEM DIR is empty, assume CONTENT DIR
    RetroArch [INFO] :: Config: loading config from: /root/.config/retroarch/retroarch.cfg.
    11083.a4     NOT FOUND
    11080.a1     NOT FOUND
    11084.a5     NOT FOUND
    11081.a2     NOT FOUND
    11085.a6     NOT FOUND
    11082.a3     NOT FOUND
    10702.b9     NOT FOUND
    10703.b10    NOT FOUND
    10704.b11    NOT FOUND
    10709.b1     NOT FOUND
    10713.b5     NOT FOUND
    10710.b2     NOT FOUND
    10714.b6     NOT FOUND
    10711.b3     NOT FOUND
    10715.b7     NOT FOUND
    10712.b4     NOT FOUND
    10716.b8     NOT FOUND
    10723.a7     NOT FOUND
    10724.a8     NOT FOUND
    10726.a10    NOT FOUND
    10725.a9     NOT FOUND
    ERROR: required files are missing, the game cannot be run.
    [INFO] :: Config: loading config from: /root/.config/retroarch/retroarch.cfg.
    RetroArch [INFO] :: Loading dynamic libretro core from: "/opt/retropie/libretrocores/lr-mame2003/mame2003_libretro.so"
    RetroArch [INFO] :: Overrides: no core-specific overrides found at /root/.config/retroarch/MAME 2003/MAME 2003.cfg
    RetroArch [INFO] :: Overrides: no game-specific overrides found at /root/.config/retroarch/MAME 2003/aliensyn.cfg
    RetroArch [INFO] :: Environ SET_VARIABLES.
    RetroArch [INFO] :: Remaps: core name: MAME 2003
    RetroArch [INFO] :: Remaps: game name: aliensyn
    RetroArch [INFO] :: Remaps: remap directory: /root/.config/retroarch/remap
    RetroArch [INFO] :: Remaps: no game-specific remap found at /root/.config/retroarch/remap/MAME 2003/aliensyn.rmp
    RetroArch [INFO] :: Remaps: no core-specific remap found at /root/.config/retroarch/remap/MAME 2003/MAME 2003.rmp
    RetroArch [INFO] :: Environ GET_LOG_INTERFACE.
    RetroArch [INFO] :: Environ GET_VARIABLE mame2003-frameskip:
    RetroArch [INFO] :: 	0
    RetroArch [INFO] :: Environ GET_VARIABLE mame2003-dcs-speedhack:
    RetroArch [INFO] :: 	enabled
    RetroArch [INFO] :: Environ GET_VARIABLE mame2003-skip_disclaimer:
    RetroArch [INFO] :: 	disabled
    RetroArch [INFO] :: Environ PERFORMANCE_LEVEL: 10.
    RetroArch [INFO] :: Content loading skipped. Implementation will load it on its own.
    RetroArch [libretro INFO] :: Found game: aliensyn [aliensyn].
    RetroArch [WARN] :: SYSTEM DIR is empty, assume CONTENT DIR /home/pi/retropie/roms/arcade/aliensyn.zip
    RetroArch [INFO] :: Environ SYSTEM_DIRECTORY: "/home/pi/retropie/roms/arcade/".
    RetroArch [INFO] :: Environ SAVE_DIRECTORY: "".
    RetroArch [INFO] :: Environ SET_ROTATION: 0
    RetroArch [libretro WARN] :: Directory /home/pi/retropie/roms/mame2003 not found - creating...
    RetroArch [libretro WARN] :: Error creating directory /home/pi/retropie/roms/mame2003 ERRNO 2 (No such file or directory)
    RetroArch [libretro WARN] :: Directory /home/pi/retropie/roms/arcade//mame2003 not found - creating...
    RetroArch [libretro WARN] :: Error creating directory /home/pi/retropie/roms/arcade//mame2003 ERRNO 2 (No such file or directory)
    RetroArch [ERROR] :: Failed to load content.
    RetroArch [INFO] :: Does not have enough samples for monitor refresh rate estimation. Requires to run for at least 4096 frames.

    Not sure what is relevant in here, but it complains about directories not being present. But isn’t it supposed to fetch the roms from the roms/arcade folder anyway?

    BTW, I tried re-installing a newer build from config, so the build of lr-mame2003 is probably more recent.

    Post count: 1827

    Have you recently updated lr-mame2003 ? If so you will need to update retroarch also as it has changes that require an updated retroarch.

    aah you did. Update retroarch and it should work.

    Post count: 4

    That did the trick, thanks!!

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.