Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #102194

    Hi, I’m trying to get lr-gpsp running and I have to be missing something simple.

    started from scratch yesterday.
    berryboot > raspbian > update&&upgrade > reboot > > binary

    post config > samba > boot to emulationstation > xboxdvr


    drop the roms at

    config xbox controller for menus, go to GBA menu, select rom, lauch,
    no love.
    #$%@, forgot bios file. google > download > gba_bios.bin > MD5 a860e8c0b6d573d191e4ec7db1b1e4f6 > \\i.p.a.d.d.y\roms\gba_bios.bin

    launch rom again, get a screen listing rom name/maker etc, then drops to emulationstation.

    Switching to GPSP the rom loads fine. ls-gpsp drops me make to emulation station.

    I am running the pie via an HDMI > DVI cable to a monitor with i believe 1280×1024 native resoluton.


    /opt/retropie/supplementary/runcommand/ line 684:  4068 Segmentation fault      /opt/retropie/emulators/retroarch/bin/retroarch -L 
    /opt/retropie/libretrocores/lr-gpsp/ --config /opt/retropie/configs/gba/retroarch.cfg "/home/pi/RetroPie/roms/gba/1986 - Pokemon - 
    Emerald Version (UE).gba" --appendconfig /tmp/retroarch.cfg


    # Settings made here will only override settings in the global retroarch.cfg if placed above the #include line
    input_remapping_directory = /opt/retropie/configs/gba/
    #include "/opt/retropie/configs/all/retroarch.cfg"


    video_refresh_rate = 60
    video_fullscreen_x = 0
    video_fullscreen_y = 0

    0x0 strikes me as an odd resolution, so i tried editing in 800×600 and it was no different.

    Any help would be awesome. I’m sure I’m just missing something silly.



    You’ll have to forgive me, i am horrible in linux. if I say anything that should be obvious, roll your eyes, pat the newbie on the head, and continue on.

    i dug around some more. ssh’d into the pi, and tried manually running the command that was showing up in /tmp/runcommand.log.

    segfault again.

    ah, but this is linux.. and linux people explain things.. somewhere…

    –help led me to -v

    -v led me to…

    RetroArch [INFO] :: Video @ 720x480
    RetroArch [INFO] :: Starting threaded video driver ...
    RetroArch [INFO] :: [VC/EGL]: Initializing...
    RetroArch [INFO] :: [SDL_GL] SDL 2.0.3 gfx context driver initialized.
    RetroArch [INFO] :: Found GL context: sdl_gl
    RetroArch [INFO] :: Detecting screen resolution 1680x1050.
    RetroArch [WARN] :: [SDL_GL]: Failed to set video mode: Could not create GLES window surface
    Segmentation fault

    so maybe the video resolution is part of the problem?

    relaunched the emulator and popped into settings, turned the resolution and refresh to the lowest possible. ran it again.

    RetroArch [INFO] :: Xbox Gamepad (userspace driver) #2 configured in port #1.
    RetroArch [INFO] :: [udev]: Pad #1 (/dev/input/event7) supports 0 force feedback effects.
    RetroArch [INFO] :: Found joypad driver: "udev".
    RetroArch [INFO] :: [CPUID]: Features: NEON
    RetroArch [INFO] :: ALSA: Using signed 16-bit format.
    RetroArch [INFO] :: ALSA: Period size: 384 frames
    RetroArch [INFO] :: ALSA: Buffer size: 1536 frames
    RetroArch [INFO] :: [CPUID]: Features: NEON
    RetroArch [INFO] :: null: [/opt/retropie/configs/gba/].
    RetroArch [INFO] :: [Data Thread]: Initializing data thread.
    RetroArch [INFO] :: [Data Thread]: Starting data thread.
    Segmentation fault

    aaaaaand now i have no clue what else…


    so I started from scratch again today in hopes of RC3 helping…

    it didn’t. I don’t have time to pull all the files at the moment, but the symptoms are exactly the same.

    also, is there somewhere else I should be asking this?


    i had a similar issue where lr-gpsp didn’t run certain pokemon games, but gpsp did. my guess is that the version of gpsp that the libretro version is built from is older, or that the porting process introduced some bugs. you can just run these games in gpsp instead, but that’s a bit annoying as it means you can’t use shaders, etc.

    logging it as an issue with lr-gpsp is probably your best bet!


    ya know.. i swear I tried several (non-pokemon) games when I first had this problem. But you are absolutely right, loaded up another game, and it plays fine. >.< I guess its not my configuration then. To lr-gpsp i go. thanks!

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.