Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • cdpie
    Participant
    Post count: 4

    Hi.

    I installed the Image from that Site.

    When I try to copy games with winSCP I get an error that there is not enough free disk space. When I run retroarch_setup it also tells me there is not enough space. I installed the image on an 8GB SD Card with Win32 Disk Imager.

    Retroarch_setup also tells me I should try raspbian_setup to get more disk space but I don’t have that file ;(

    Can anyone help

    MrCooper2012
    Participant
    Post count: 2

    Heyo. From the command line go to “sudo raspi-config” (with no quotes). I believe the first option should say “Expand Filesystem”. Select that, then it will prompt you to reboot. After a reboot you should have access to the full storage size. If you ever have to reimage, you will have to do this again.

    fistwielder
    Participant
    Post count: 38

    I came across this issue once.
    To resolve it I made sure I started with a clean SD card that I fully formatted as FAT32 (no quick format). Then I confirmed that it had 8gb of storage space after formatting it. Lastly, after installing the image on the SD card with Win32DiskImager and booting up my Pi, I expand my file system in raspi-config.

    The easiest way to clean a disk and get rid of partitions before formatting with Windows is by using diskpart:
    1) In Windows click Start then Run.
    2) Type diskpart then hit enter.
    3) After it opens, type “List Disk” then hit enter. This will list your disks with their disk numbers on the left.
    4) If your 8gb SD card is disk 1, type “select disk 1” then hit enter (use whatever disk # your sd card comes up as). Do not select the wrong disk.
    5) Type “clean” then hit enter. This will clean your disk.
    6) Type “create partition primary” then hit enter.
    7) Lastly, type “exit” then hit enter to close diskpart.

    After cleaning your disk, format it as FAT32. Do a full format, not a quick format.

    Image your SD card using the latest image (2.6) with Win32DiskImager.

    Put the SD card in your Pi and boot it up. After your pi boots into EmulationStation, you can hit F4 if you have a keyboard connected to it, to exit to a command line. From there type “sudo raspi-config” then hit enter. Select the option to expand your file system then expand it.

    This worked for me. Good luck.

    cdpie
    Participant
    Post count: 4

    Thanks all for your answers.
    I didn’t knew that I could just write sudo raspi-setup. I thought I need to have the “executable” and I didnÄt found that!

    So problem is solved :D

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.