Homepage Forums RetroPie Project Controller Configuration in RetroPie Logitech F310 Controller help

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #94801

    Hey guys,

    I’ve been digging around for weeks, watching videos, reading articles, fudging with config files … and I’m still at a loss here.

    On my Pi 2, I can’t get my Logitech F310 Gamepad working for the life of me.

    I’ve installed the xbox drivers, made them boot up at startup, etc. Still nothing.

    When I go to the ‘Configure input devices for RetroArch’ option in RetroPie setup, it immediately exits back to the blue screen and splashes a ‘success’ type message.

    I’m on the latest version of RetroPie and Raspbian.

    Any help would be GREATLY appreciated!


    So after getting a fresh copy of the latest RetroPie release, running rpi-update, and connecting my controller, going to ./retropie_setup.sh, and selecting the option for setting up a RetroArch controller, it immediately returns this message:

    The configuration file has been saved as .cfg and will be used by RetroArch from now on whenever that controller is connected.

    This is without any xbox drivers installed. The strange thing is that my controller worked briefly when I first got my B+. It then stopped working completely. Now it doesn’t work on my brand new Pi2 either.

    I’m really at a loss here. It’s recognized by my Macbook when I plug it in, so I’m pretty sure the controller is still functional.


    On my RPi2 this controller worked perfectly on a clean RetroPie install. No configuration or drivers needed.

    Does the controller work on a PC? Perhaps you have a pairing issue?


    strawberrytau: I am looking at purchasing this controller. Does the Logitech F310 work on all emulators? -NES, SNES, SEGA, GENESIS, MAME, N64, AND PlayStation?

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.