Homepage Forums RetroPie Project Everything else related to the RetroPie Project Libretro MESS in new Retropie 3.6 ?

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #118924


    Yesterday I installed latest RetroPie 3.6 on my Raspberry Pi 2, compiled libretro mess from experimental setup menu and get lr_mess folder with mess_libretro.so core file inside, but cant start any system to work.
    Edited emulators.cfg in opt/retropie/configs/mame-libretro/ to lr-mess=”/opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-mess/mess_libretro.so –config /opt/retropie/configs/mame-libretro/retroarch.cfg %ROM%”
    Renamed mame/hash to mess/hash in RetroPie/BIOS folder, put some ziped bios roms (eg. coco.zip and coco3.zip) to roms/mame-libretro folder and try to start from emulationstation menu, but always get me into retroarch menu instead to start some of those Coco computer emulator.
    Didnt change anything in es_systems.cfg.
    Whats is the right usage of libretro mess emulator, I cant get any tutorial about it?
    Obviously I missed something, but dont know what.
    Can somebody help me to start libretro mess on Retropie?


    I’ve had the same problems. the dev for that needs to write up some documentation on it, he just hasn’t gotten to it yet.. you can check the github commit history and there are some notes on it but MESS is very very picky about file paths and as you’ve seen it is experimental for a reason for the time being.


    Thanks for quick reply.
    I had some experience with standard mess build, but obviously its not enough here.
    I just cant figured out, whats I am doing wrong.
    Found this tutorial here https://www.youtube.com/watch?v=Kq04IoKdbRA, tryin online updater in retroarch menu, he update all stuff and put some of this in home/pi/.configs, but cant find mess core or start it, even if I manually select them in retroarch menu.
    It takes me long time to compile and feeling preety much frustrating about this.
    I also found this small tutorial, but still no luck to start libretro mess:
    Any help about make this work is welcomed.


    Hi. I’m the one that created the script that adds lr-mess to Retropie. I don’t blame you for not knowing how to get it running – most of the libretro developers don’t know either or give conflicting accounts of how to get it running.

    *WARNING: This looks long and intimidating. It’s actually quite easy, but I just have to explain to you how things work so that’s why it’s long. Most everything important is done by the installation script.

    Follow these instructions exactly to the letter. If you are going to ask a question such as “what if I do this other thing?” the answer is instantly “no”. Not because I’m an asshole or anything like that, but because the core is extremely rigid with how it works. Attempting to do anything different than what I’m presenting you here is going to end in tears. Do not attempt to follow any other person’s tutorial or YouTube video as it may stop you from being able to get things working properly. Undo any changes you have previously made to try to get it running first.

    A few explanations first.

    * lr-mess is based on latest GIT revision of MAME whenever you attempt to compile it.

    * Using lr-mess in the way I am telling you here will only work with MAME Software List ROMs matching the version of MAME you are compiling. Any other set of ROMs will not work. A good guideline for avoiding bad ROMs: If you are downloading them through HTTP from a public ROM site, they are not likely to work. The ROMs cannot be unzipped or renamed.

    * At this point, the lr-mess script will automatically set up lr-mess for you only for systems that are known to run well on a Pi 2 with an overclock. If the system is not listed in the lr-mess script, it either has not been tested or has been tested and ran at a bad speed.[

    * Systems that have been tested and run well with lr-mess so far:
    Colecovision (100% speed, driver: coleco)
    CreatiVision (80-100% speed, driver: crvision, not added to the script yet)
    Emerson Arcadia 2001 (100% speed, driver: arcadia)
    Nintendo Entertainment System (100% speed, driver: nes)
    Nintendo Gameboy (100% speed, driver: gameboy)
    Sega Dreamcast VMU (100% speed, driver: svmu)

    * Systems that have been tested and don’t run as well with lr-mess so far:
    Amstrad GX4000 (65% speed, some games still feel very playable, driver: gx4000)
    Atari 2600 (70-85% speed, driver: a2600)
    Atari 5200 (50-60% speed, driver: a5200)
    BBC Micro B (25% speed, driver: bbcb)
    Intellivision (Fails to find/load saa5050 ROM, driver: intv)
    Nintendo Gameboy Advance (50% speed, driver: gba
    Sega Game Gear (80% speed, driver: gamegear)
    Sega Genesis (46% speed, driver: megadriv)
    Sharp X68000 (14% speed, driver: x68000)
    SNK Neo Geo AES (60-65% speed, driver: aes)

    All systems other than those listed above have not been tested.

    *** Instructions ***

    Run the lr-mess script from the experimental menu. Compile should take about 3 hours on a Pi 2.

    Check your BIOS folder after compilation and see if a folder named “mame” exists. Within it should be a folder named “hash” that includes a bunch of xml files. These are the software lists that lr-mess requires. If they exist, we likely compiled properly.

    Go to your roms directory, wherever you have it (default: /home/pi/RetroPie/roms/) and create a directory named after the driver you wish to use. Place the BIOS file for that driver in the root of your roms directory.

    For example, if you wanted to run the Donkey Kong Colecovision rom (dkong.zip) through lr-mess, you would place your files like this:

    Main rom directory (/home/pi/RetroPie/roms)
    +-Coleco Driver BIOS zip: coleco.zip (/home/pi/RetroPie/roms/coleco.zip)
    +-coleco (/home/pi/RetroPie/roms/coleco)
    +- dkong.zip (/home/pi/RetroPie/roms/coleco/dkong.zip)

    If the driver you wish to use does not require a ROM, you do not need to put one into your roms directory.

    Check /opt/retropie/configs/all/retroarch-core-options.cfg and make sure that MAME CLI launching, MAME software lists and MAME auto media type are turned on. The compilation script should set these by default at the bottom of the file, but just make sure.

    You may need to add .zip and .ZIP to your extensions in /etc/emulationstation/es_systems.cfg and restart emulationstation for it to pick up your ROMs.

    If all goes well, you should get the game running when you select it from emulationstation. If it quits back to emulationstation immediately, you likely have bad ROMs or something else unexpected happened.

    Let me know how you get on and what performance you see with systems you try and I’ll eventually add this to the wiki proper.


    Thanks man, it works now. :)
    Never relised, how much sesitive mess is, about names and correct crc cheksum for each game and thats makes all the trouble.
    I noticed ini file for each individual system in roms/BIOS/mame folder, but it contain much less content for settings, than full MAME/MESS.
    Also I want to tweak some video option to gain more speed, but cant find those sections.
    Maybe I need to make those changes in retroarch settings?
    Id like particulary to get full speed for galaxy computer, but for now I only acheive about 60%, which is quite unusable.
    Is it possible to do something about this.
    Once again, thank you very much, your answer was very useful.


    Glad to hear you got it working. I haven’t made any attempts to get better performance yet. I do notice that it appears to be running in a high resolution when I look at the text in yellow at the bottom left. Maybe just running at a lower resolution using the runcommand dialog box that comes up before a game starts would be enough. I’ll give it a shot.


    Yes, thats wold be a good idea, please tell us if you make any progress about this.
    Also, do you know is it possible to compile libretro mess from some older versions?
    Iv heard that versions 0.149 or 0.150 are much less hardware dependent than latest ones.
    Do I need to heavily change script from experimental menu, or just pointed to older source package?


    Unfortunately resolution switching did minimal improvement, really.

    As far as I know, libretro deleted all their code relating to separated mess cores when MESS and MAME merged a little while ago, so the oldest you’d be able to do is maybe when they merged which is more recent than the revisions you mention.


    I have one more question if you can help me with this.
    Id like to add some additional video settings like scalemode, but i dont know exactly where and which config file I should edit.
    Found txis explanation about additional options, but stll no luck:

    Obviously I dont know valid format for their use.
    Any hint?


    You should be able to do anything you want by editing the system specific retroarch.cfg in /opt/retropie/configs/systemname/.


    Yes, you right about that.
    Just dont know is it possible to add scalemode option and how.
    In standard MESS, there is mess.ini file in the same directory, which can be edited and scalemode option is present, but I dont know is it supported in libretro version.
    I tried to add the option video_scalemode = “yv12” but it doesnt work.

    ∆ + 0 / 9

    hi, I also would like to run Arcadia 2001 (via MESS) on RetroPie. How did you get it running? I’ve followed the instructions above and in the wiki but when I load a game it only goes to the RetroArch Main Menu (MAME 0.171) instead of loading the game.

    My “mess” roms folder looks like this:
    /home/pi/RetroPie/roms/mess/(arcadia doesn’t need any zipped bios)


    I put this in “es_systems.cfg”:

    .zip .ZIP
    /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ lr-mess %ROM%

    and in “emulators.cfg” I put this:
    lr-mess=”/opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-mess/mess_libretro.so –config /opt/retropie/configs/lr-mess/retroarch.cfg %ROM%”

    Thanks for your help!

Viewing 12 posts - 1 through 12 (of 12 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.