Homepage Forums RetroPie Project Controller Configuration in RetroPie Keyboard numbers don't work in Doom

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #115810

    Hi all,
    hoping for some assistance:
    I am using a wireless Logitech keyboard and an SNES controller with Doom. I can’t select a weapon, which is normally done using the numbers on the keyboard.

    The other functions on the keyboard work correctly in Doom. I’ve verified that the numbers work (along with everything else) when typing at the command prompt.

    I’m using a vanilla 3.4 Retropie image and have not changed the control mapping for Doom (or anything else for that matter).

    I’ve tried everything I can think of, and haven’t found anything by poking through the forums or googling. Does anyone have ideas?


    Just to verify is it both the top numbers and the numpad that don’t work ? Are you using pr-boom or zdoom? Have you tried reconfiguring the controls with retroarch as the default is a retroarch based emulator


    Because the keyboard has a touchpad built in, it has no numpad to the right. I’m having trouble with the numbers across the top of the keyboard.

    I’m using the Doom that shows up under the “Ports” menu on a 3.4 vanilla image for a Pi B+. I expect that’s the PRBoom version.

    How do I reconfigure retroarch controls as the default? The only control configurations I’ve looked at are via desktop->retropie->edit retropie/retroarch configurations->edit common configurations.

    Thanks for your time.


    would be /opt/retropie/configs/doom/retroarch.cfg

    see this page


    I’m just assuming that they coded in hooks for those original values in the game, but I’m not entirely sure as I haven’t looked into it all that much.


    Thanks for hanging with me on this.

    The article covers configuring game controller mappings (which could easily be mapped to a keyboard) which is in the ballpark, but I couldn’t find anything on configuring the keys on the keyboard. The doom.cfg file, which I’ve poked around in by selecting “manually edit configuration” through the menus, has no mappings by default.

    Does anyone have ideas on how to manually map keyboard keys to themselves rather than game controller functions?


    this is taken directly from the default retroarch.cfg

    input_player1_a = x
    input_player1_b = z
    input_player1_y = a
    input_player1_x = s
    input_player1_start = enter
    input_player1_select = rshift
    input_player1_l = q
    input_player1_r = w
    input_player1_left = left
    input_player1_right = right
    input_player1_up = up
    input_player1_down = down
    input_player1_l2 =
    input_player1_r2 =
    input_player1_l3 =
    input_player1_r3 =

    l2 and r2 are the next/ previous weapon buttons for override syntax you may have to put the button in quotations like input_player1_l2 = "1"

    You can also check out floobs video for core input remapping options

    It looks like they only have controller hooks for next and previous weapon so I don’t think its possible to use the numbers as one gun per number selector.


    I’d forgotten that there were “equip previous” and “equip next” in addition to the numbers for each weapon. That is enough to get me there; there are several available buttons on my controller. I can also map them to keys on the keyboard if I choose to go that route.

    Thank you!

    I’ll report back with the exact syntax should anyone want it someday.



    By default if you are using a gamepad they will be mapped to Top left and Top right triggers.


    I have an 8-key SNES controller, there’s only one left and one right, set to strafe left and strafe right. The “Y” and “B” buttons are available, so I’m going to try to map to them.


    When I tried to manually edit the configuration files I found that I couldn’t insert the “#” character, a.k.a the “pound sign” if your American or the “hash mark” if you’re a Brit. My keyboard region and layout were set to English-Great Britain instead of English-US; I’m American and have a US-style keyboard, so this caused some problems. To resolve it I set the root password and edited various Debian files to set my region, language, keyboard model, and keyboard layout to reflect US-English. I could finally edit my retroarch configs files and actually comment something out instead of getting a British Pounds Sterling symbol.

    My keyboard now works correctly and I can edit text files, work at the command prompt, etc. to my hearts content. The keyboard numbers work as expected in text editors and at the command prompt, so Debian is happy. Still I couldn’t get the numbers to work in Doom (prboom) to select weapons.

    So in looking through the Doom settings there are “next item” and “previous item” that move you through the menus and there are “next weapon” and “previous weapon” that are found much later in the settings. It’s important not to confuse them.

    By default, the “next weapon” and “previous weapon” are mapped to “m” and “n”. I tried the “m” and “n” keys, and they don’t work in Doom either, despite the fact that the letters used to move, fire, and turn DO work. I tried booting with no game controller to see if it was interfering with keyboard controls. Nope, same symptoms with no game pad–no ability to select weapon from numbers or letters.

    Editing the doom.cfg and telling it to use “button_2” or “button2” didn’t work.

    I tried remapping the previous and next weapons to different keys from within Doom, and found that the “press enter to change” just exited me from the menu, but that I could press the “A” button on my game pad to get into the mappings. So using the “B” and “Y” buttons (logical buttons 2 & 3) I tried to remap the “M” and “N” keys. It worked, but the game said that these are the “shift” and “alt” keys.

    So I can now select weapons, but the numbers don’t work and the keymappings are still essentially screwy. I’ve worked around my problem, but not understood it, much less solved it.

    If anyone has ideas regarding how prboom, retroarch, and debian interactions might cause this, I’m all ears. Also, I’m assuming that the “ports” menu are for games ported to work directly on the Pi without an emulator layer. Someone please correct me if I’m wrong.

    Thanks again for taking the time to read this. I hope it helps someone else who has the same problem.


    This video shows an easy way of switching your keyboard.

Viewing 11 posts - 1 through 11 (of 11 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.