Homepage Forums RetroPie Project New to RetroPie? Start Here! Keyboard mapping trouble

Tagged: ,

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #104909


    I installed Retropi 3.0 with USB keyboard and it was working while ago.

    I wasn’t happy the way keyboard was mapped in the first run and I tried to do remapping by deleting the es_input.cfg file found in:


    Now when I press a key from the keyboard, the emulation station shows up that in can recognize the keyboard, but this time I’m not able to map any keys (the OK button just stays grayed out and it just displays the text “Hold a button on your device to configure it…”).

    Is there a way to proceed from this to somehow? I can connect the device via SSH, would I be able to get some default es_input.cfg from somewhere and edit that?

    Thanks already…


    re-install emulationstation from binary via menu 5 of retropie-setup and it will reset its input configuration.

    However it sounds like you might have another issue, as it should be able to pick up the keyboard despite your changes. With USB devices not working as they should, the first thing to check is PSU and USB cable – as if the pi isn’t getting enough power than can cause problems.


    Did you come up with a solution? I am having the same issue.

    New pi2b, downloaded and booted the sd image. It gives me “Welcome, No gamepads detected” screen. I hold a button on the keyboard and it gives me the “Configuring Keyboard” screen. I assign buttons for everything, and then it highlights “OK” at the bottom. I can use the up/down keys to scroll up and down the list of keys, but nothing I press will get past the screen (except F4, but it doesn’t seem to save the config).

    I don’t think it’s an issue with the keyboard; I have tried more than one, and I don’t have anything else plugged into USB so I doubt there’s an issue with the power draw.

    I have tried manually editing es_input.cfg but either it isn’t loading or my file is invalid (does anyone have a working example?)


    You should open a new thread – you have a different problem.

    the button for “a” should work. No idea if not – but it’s not a retropie bug but something with your setup. check your pi is getting enough power etc. Perhaps try another Key for A also ? Are you running from a fresh rpi3 image ?


    Sorry for hijacking the thread, I thought that I was having the same issue and that two data points would help solve it easier.

    [quote=105060]the button for “a” should work[/quote]

    Thanks, that did the trick. (I feel like such a noob now…) In retrospect it makes sense, but I didn’t see anything on the “First Installation” page and I kept trying the “start” button (and then randomly mashing the keyboard but apparently didn’t happen to hit ‘a’).

    Again, sorry, and thanks! And I do hope that OP can solve his problem too.


    glad you have it sorted.

    Please do add it to the wiki https://github.com/RetroPie/RetroPie-Setup/wiki/First-Installation so others can benefit. thanks.

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.