Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • jazman23
    Post count: 8

    HI Guys,

    Ive recently bought a Raspberry PI 2 after using a PI Model B+ for a few weeks and ive run into a few issues which i think are purely Retroarch related

    Ive run all the setups etc and things all work fine in emulation station. Ive registered 2 controllers with Retroarch which are picked up when I launch a retroarch emulator for example PSX so I can play games with the controllers.

    the 2 controllers I have are:
    Speedlink XEOX – I use this in PC mode, it is registered as a generic USBGamepad
    Mad Katz Wired Xbox 360 Gamepad (Picks up as the Mad Katz name)

    The issue I have is that when I run PSX for example, both controllers layouts are messed up. Like for Example, If I press the B button on both controllers its as if Im pressing the A button.

    Ive looked at the controller config files in Retroarch and it doesnt appear to be mapping the buttons correctly, it’ll record all the button numbers wrong, for example, Button A on the controller is Number 1, but Retroarch has registered it as Button 0, but my controller has no button 0.

    IVe tried manually editing each of the controllers Configs, setting the correct numbers for the buttons and saved the file, but it never carries through to Retroarch, it just stays exactly the same.

    I also have the issue where I cannot use the Keyboard on Any retroarch emulators, its just a generic USB keyboard that came with my Pi kit, it works outsde of retroarch. It also worked perfectly fine when I was using Retroarch on my Raspberry Pi 1.

    I dont know if i had the same issues with the controllers on the Pi 1 as it wasnt powerful enough but the controlellers seem fine in emulators such as the Snes emulator and the Sega emulators. Other emaulators ive had the same issues with are the Nintendo 64 emultors

    Ive looked all over the place and havent been able to find a solution :/ can anyone shed any light on this?

    Post count: 8

    Ive also tried to remap the inputs using the retroarch menu while ingame and it doesnt appear to write anything to the config files

    Any advice on this would be appreciated

Viewing 2 posts - 1 through 2 (of 2 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.