Tagged: ,

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • kaitain
    Participant
    Post count: 8

    Hi,

    RetroPie newbie. (Just got my first Pi yesterday.) The RP project sounded like fun, so I downloaded the latest image onto a fresh FAT32 SD card and started the thing up. I noticed that the wifi wasn’t set up, though, which seemed to be a bind for scp et al.

    Anyway, after an hour or so of frustrated faffing, I decided the simplest solution might be to add lxde to the card and install/use wpa_gui. This duly worked, and I got my roms transferred across using scp. Hurrah.

    Except not quite hurrah. Because now after the boot chugs along happily for several seconds (the colourful RetroPie splash screen), instead of going to the EmulationStation screen, it takes a different route, to a dour-looking grey login screen that looks like a Sun SPARC circa 1996, and then after a few more seconds, gets depressed and dumps me out to the command line.

    Now, I’ve figured out that from here I can relaunch manually, by calling
    emulationstation
    …although only after I’ve killed X by calling e.g.

    sudo service lightdm stop

    And I have to do this every time.

    Now I *assume* that it was my installation of lxde that interfered with RetroPie’s usual boot, and its ability to launch EmulationStation. I had wanted the ability to drop out of ES and start lxde if I wanted to, but I hadn’t wanted to force the services to start up automatically that would prevent ES from launching (which is what I *think* is happening).

    To restore the smooth boot, I’ve wondered about disabling the lightdm service altogether, but I don’t know if that would also leave me unable to launch lxde on the occasions I wanted to do so. What is my best option here?

    herbfargus
    Member
    Post count: 1858

    Really you shouldn’t need lxde just to configure wifi. If I were you i would probably just reimage your SD with a fresh install and follow this video to set up your WiFi:

    I don’t know too much about how lxde affects the boot sequence. You could always try going into the set up script and re-enabling emulationstation to start on boot but its probably easiest to just reimage without using lxde (it takes up a fair amount of space on the pi).

    cacophony555
    Participant
    Post count: 126

    I had a similar issue after doing a “sudo apt-get install lxde”.

    I fixed it by doing “sudo raspi-config” and modifying the boot setting to boot to the command line. After that emulationstation started up fine on reboots.

    kaitain
    Participant
    Post count: 8

    Nice one. That did the trick. And still launches lxde if you exit the ES menu and start it from the command line with startx.

    kaitain
    Participant
    Post count: 8

    Useful video; thanks. I think I may have had the same issue mentioned by the guy in the vid re: power cycling on the wifi dongle, so I’ll have to give that power command a try.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.