Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • fonzman
    Post count: 7

    Hi Folks!

    I just recently installed RetroPie to my RaspberryPi and I am really happy with it.
    The only thing that bugs me is, that the “input_enable_hotkey_btn” is simply ignored!

    For example, simply pressing “input_exit_emulator_btn” is enough to exit the emulator, without any need of pressing the hotkey_btn.

    I tried different controllers and put the two lines nearly everywhere in my config files:

    input_enable_hotkey_btn = "8"
    input_exit_emulator_btn = "11"

    (btn 8 is select on my controller and btn 11 is L3 on my controller)

    I tried the controller-specific files retroarch creates in /opt/retropie/emulators/RetroArch/configs
    as well as /opt/retropie/configs/all/retroarch.cfg
    I even created /home/pi/RetroPie/configs/all/retroarch.cfg (whicht didn’t exist!) and put the lines there to no avail.

    Is there any specific setting to enable the use of a hotkey_btn in RetroArch? Did I miss something?

    For clarification: should all the buttons I define after the line input_enable_hotkey_btn only be active while holding down the hotkey? Or how does RetroArch decide which btn to use in combination with the hotkey_btn?

    best regards,

    Post count: 34

    I’m not entirely sure what you are asking here.

    So when you press L3 on your controller, the emulator exits?

    Or do you want this to happen, but would want to hold SELECT down before pressing L3 to exit the emulator?

    My setup is similar to yours – I have assigned the hot key to L3 but then have the exit emulator button assigned to the PS button my my PS3 controller (connected by Bluetooth) and it works just fine.

    Have you manually assigned the buttons by editing the retroarch.cfg file or have you gone through the emulator menu and then input settings? I did the latter and mine works if that helps?

    Post count: 7

    I want to press “select + L3” to exit the emulator.
    however, it already exits if I only press L3.

    I created the configs using the “Configure RetroArch controller” option in the retropie-setup menu, and afterwards inserted the two lines for input_enable_hotkey_btn and input_exit_emulator_btn.

    If I open the RetroArch menu inside an emulator (by pressing F1), I see both assigned buttons with the word “auto” in front (because it takes the settings from /opt/retropie/emulators/RetroArch/configs ).

    Post count: 1827

    Does this behavior change when you set the parameter input_enable_hotkey to some value? There might be a dependency on this parameter …

    Post count: 5

    What file exactly did you put these hotkeys in? they’re supposed to be in the retroarch.cfg file, also you don’t need the quotes (mine works fine without it) and make sure input_exit_emulator_btn is right below input_enable_hotkey_btn with no empty line in between

    Post count: 7

    Yes, its working!

    Thanks for all the suggestions.

    For future reference: the only cfg-files that matter are in ‘/opt/retropie/configs’
    In my case I added the two lines to ‘/opt/retropie/configs/all/retroarch.cfg’

    (My ‘/home/pi/RetroPie/configs/retroarch.cfg’ was simply ignored)

    I also set ‘input_enable_hotkey = tab’
    (Perhaps that triggered the ‘input_enable_hotkey_btn’ to work … I don’t know)

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.