Viewing 3 posts - 36 through 38 (of 38 total)
  • Author
    Posts
  • JP
    Participant
    Post count: 1

    Hello!
    I use 2.3 version and two cheap SNES-like USB controllers. I followed the instructions and now have brilliant configuration to play SNES roms. And when I play SNES emulator, everything’s fine. But when I try to play NES roms, I have some issues. For example, when I push X button, the system saves the state and kikcs me out of game. L,R and Y keys do not work at all, select+start combination doesn’t make me to exit the game. Also, I expect X and Y buttons to work as turbo A and B, want to save, load and quit games, as I’m able to do it in SNES games.
    I know, that in /opt/retropie/configs/nes there is a special config exactly for nes, but what should I write there? Or is there a special converter from these configs to fceu-next config? BTW, I couldn’t find, where fceu-next keeps input configs. I know that fceux keeps config in a special file in a directory ~/.fceux/, but it is not fceu-next…
    And the same situation with Mega Drive. The difference between gamepads makes me being not able to play SMD games =(

    But in any way, your RetroPie project is awesome! Thank you very much!!!! =)

    mirage
    Participant
    Post count: 6

    [quote=83786]…I have some issues. For example, when I push X button, the system saves the state and kikcs me out of game. …
    [/quote]

    I just experienced the same thing. Start button would make cursor go down and B would act as escape. After many minutes of trying to figure it out, I saw what was wrong!

    [quote=13708]Exiting the emulator with the controller has been discussed many times. It works the same in 2.2 as in older versions.

    You have to set up a hot key so that you press select + start. Try adding the following lines to the config file.

    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”
    [/quote]

    If you copied the code lines here above mentionned in atimmins’s post to your retroarch.cfg you’ll have to change the quote signs for this: “” and not “”

    By correcting this it all works good for me!

    ***[edit] This forum seems to publish the quotation marks in the wrong format. Might have to do with my regional settings too. Anycase, just make sure you use the same quotation marks as the rest of you .cfg file.[/edit]

    davinel
    Participant
    Post count: 1

    [quote=85257]If you copied the code lines here above mentionned in atimmins’s post to your retroarch.cfg you’ll have to change the quote signs for this: “” and not “”

    By correcting this it all works good for me!

    ***[edit] This forum seems to publish the quotation marks in the wrong format. Might have to do with my regional settings too. Anycase, just make sure you use the same quotation marks as the rest of you .cfg file.[/edit]
    [/quote]
    I’ve only registered to thank you, now it works :D

    https://www.dropbox.com/s/1e4sv6n0e2nt28g/comillas.PNG?dl=0

Viewing 3 posts - 36 through 38 (of 38 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.