Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • morias
    Participant
    Post count: 28

    I have been trying out video shaders and I am very pleased with the result. They make games acceptably smooth on large lcd screens that the games were never designed to run on.

    I can set up the shaders by entering the menu in Retroarch by hitting F1. However, I can never make the shader settings stick.

    I am happy with the hq2x shader and have added the following to my retroach.cfg

    video_shader_enable = “true”
    video_shader_dir = /opt/retropie/emulators/RetroArch/shader/
    video_shader = “/opt/retropie/emulators/RetroArch/shader/hq2x.glsl”

    There is also a hq2x.glsp file but using that also doesn’t work.

    Every time I restart the retroarch emulator, it defaults back to the standard 3 shaders.

    I would appreciate some help if anyone else has applied the shaders permanently.

    Anonymous
    Inactive
    Post count: 59

    Try editing the individual emulator config files. Each one of those overrides the general one and may have something else set as the default.

    morias
    Participant
    Post count: 28

    Thanks for the suggestion, but my individual emulator config files basically are empty apart from a few joystick overrides I have put in them to switch some keys depending on the emulator.

    However, I have also thought that perhaps the 3 shaders which are setup by default may be stored somewhere, I just don’t know where and the logical place where the settings would be in the config/all/retroarch.cfg does not contain the settings.

    morias
    Participant
    Post count: 28

    This is some homework for me tonight. I read this page before, but I have read it a little closer now.

    https://github.com/libretro/RetroArch/wiki/RGUI

    It says:

    When you apply shaders, the RGUI shader settings are saved to a temporary file (either rgui.cgp or rgui.glslp) and loaded. The file persists after RetroArch exits. The file is saved to video_shader_dir directory in config. If you always want to load the RGUI preset on bootup, you can set video_shader option to this file.

    Further it says:

    While you are changing settings in runtime, they are not saved to disk afterwards on PC by default. If you want RetroArch to automatically write back the config, either set config_save_on_exit = true in config, or enable this under Settings -> Config Save On Exit from within RGUI.

    I will see if this fixes my problem and report back.

    morias
    Participant
    Post count: 28

    Time for my mea culpa. After fiddling around and not making it work, I rechecked the individual emulator files and found that the SNES and Megadrive one indeed to have override settings. After turning these off my shader settings are indeed sticking.

    spanner
    Participant
    Post count: 17

    Hi How did you do it …step by step please..?

    Floob
    Member
    Post count: 1629

    This should help

    and this one

    https://www.youtube.com/watch?v=owsdsyIDU6A

    gizmo98
    Participant
    Post count: 452

    Just check out if shaders are disabled in your individual retroarch.cfg files. The current RetroArch-Setup disables shaders at default:

    https://github.com/retropie/RetroPie-Setup/blob/master/scriptmodules/emulators/retroarch.sh#L111

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.