Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • whatgoesup
    Post count: 4

    Hello all!

    Brief Backstory: So I’m new to the forum, new to using RetroPie and just received my first Raspberry Pi as a late Christmas gift. As soon as I received it I knew I wanted to…play all of my favorite games and relive my childhood! I successfully got RetroPie up and running last week. Between the content posted here, GitHub and the amazing YouTube videos it was almost too easy (big thanks to the entire community!). I have successfully paired and configured my PS3 controller and got the Bluetooth working last night to prepare from some intense weekend gaming as I’m in NJ trapped in the blizzard.

    Problem: I was attempting to get the PS3 joysticks working and accessing some of the directories and files I’ve seen others discuss was confusing me as was not able to locate the same content. I launch Crash Bandicoot and entered the RetroArch menu. I saw an Update section and thought “That sounds like a good idea”. So, I ran down the list and updated everything I saw. Jumped back to Crash and realized the joysticks were still not working, but thought that the proper files may not exist for me to edit. I attempted to exit the game by using START+SELECT which has worked since Day 1. Nothing. I went back to RetroArch and had to exit the Rom by Quitting RetroArch. I decided to reboot thinking maybe things would go back to normal or maybe that would solve the joystick issue. After reboot, still nothing. Tried some other Roms and it was the same result.

    I’ve found some videos where the RetroArch PS3 Controller configs are visible and everything seems to match up. Attempting to run and selecting 314 Configure input devices for RetroArch only prompts me for the keyboard. I then used 310 to Remove PS3 controller config. thinking this would be like hitting the reset button. After reconfiguring the controller again, the issue still remains.

    At this point I’ve reached my capacity as I’m just too new to this. I’m afraid to venture any further on my own, I’ll mess something else up in the process. I can live without the joysitck support for now. I just want to get things working correctly again. Sorry for the long post and thank you to anyone who takes to time to read this and assist in anyway possible!

    Pi Model: 2 B
    RetroPie Version Used: Unsure where to find, but I ran all recommended updates as of Last Friday
    Built From: SD Image
    USB Devices connected: Wireless Keyboard, PS3 Controller
    Controller used: PS3 Controller
    Error messages received: N/A
    Guide used: & +
    File: Unknown but I’m assuming things went wrong with RetroArch
    Attachment of config files: N/A
    How to replicate the problem:

    Post count: 4

    Below is what is contained in my PLAYSTATION(R)3 CONTROLLER.cfg file:

    input_device = "PLAYSTATION(R)3 Controller"
    input_driver = "udev"
    input_r_y_plus_axis = "+3"
    input_l3_btn = "1"
    input_r_x_minus_axis = "-2"
    input_r_btn = "11"
    input_save_state_btn = "11"
    input_l2_btn = "8"
    input_start_btn = "3"
    input_exit_emulator_btn = "3"
    input_l_y_minus_axis = "-1"
    input_l_btn = "10"
    input_load_state_btn = "10"
    input_up_btn = "4"
    input_r_y_minus_axis = "-3"
    input_a_btn = "13"
    input_b_btn = "14"
    input_reset_btn = "14"
    input_down_btn = "6"
    input_r2_btn = "9"
    input_l_x_plus_axis = "+0"
    input_l_y_plus_axis = "+1"
    input_r3_btn = "2"
    input_right_btn = "5"
    input_state_slot_increase_btn = "5"
    input_x_btn = "12"
    input_menu_toggle_btn = "12"
    input_select_btn = "0"
    input_enable_hotkey_btn = "0"
    input_l_x_minus_axis = "-0"
    input_y_btn = "15"
    input_left_btn = "7"
    input_state_slot_decrease_btn = "7"
    input_r_x_plus_axis = "+2"

    EDIT: I’m seeing two separate .cfg files one is “PLAYSTATION…” but the other is “SonyPLAYSTATION…” The latter seems to be my original from 1/17 while the former is from 1/23.

    Could this be as simple removing the .cfg from today?

    EDIT: Upon further inspection the content of the files appear to be identical aside from the name.

    Post count: 4

    Well I determined that I did not have the most recent version of RetroPie. Decided to just start over from scratch and all is well. Still no joysticks, but now that I’m running on the current build it might be easier to resolve on my own.

    Post count: 13

    Have you had any luck or is anyone able to advise? I’m having the exact same problem!

    Post count: 4

    I had to completely start from scratch. And everything worked as normal. I have yet to get the joysticks working, but I haven’t invested much time into solving the issue. I did run a jstest and everything seemed to check out fine.

    Post count: 13

    Is it just the psx the analog doesn’t work properly? That was the only
    Emulator I had an issue with. Everything else worked fine.

    Just means having to change each console retroarch.cfg.

    When I changed mine on the psx emulator I had to go into the core-options-input and manually change that file back to user 1 joypad “standard” to get the controller working in there again. But somewhere it has ruined the hockey’s input as per yours and not matter what I do I can’t get them back.

    I’m going to try installing a fresh image to an as card today, and swapping all the retroarch cfg files to standard ones.

    If that fail it’ll be a fresh install which is really like to avoid as I have kodi all setup working as I want it :,(

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.