Viewing 1 post (of 1 total)
  • Author
    Posts
  • kaitengiri
    Participant
    Post count: 1

    I’m just having the most frustrating time with this issue, and I’ve tried a lot of different things.

    Issue:
    I have a 360 Arcade Stick made by Hori called the VX
    http://www.play-asia.com/hori-fighting-stick-vx/13/7049ou
    It confirmed works on my PC and my xbox 360. Everything is fine there

    I installed a RetroPie SD image of 3.5 onto an SD card, everything went well there.

    No matter what I do, I can’t get the stick to register the LT and RT buttons when I press them. There are registered as analogue so they start at position ~37560 or something and when depressed, are at position ~(-)37560. Everything else on the controller works fine.

    xboxdrv will not pick up on it no matter what. I’ve tried having the controller plugged in from before power on, I’ve tried editing /etc/rc.local to include a line to reference it by the device id that shows up in lsusb. I have tried the manual, AND the daemon install on the github file for installing xboxdrv. I have tried installing it automatically through the retropie configuration. Nothing works.

    To make matters worse, when I blacklist xpad, the device no longer responds to even jstest. The light blinks on and off, but it does nothing no matter what I press.

    And just to add insult to injury, I have a wireless USB dongle for 360 controllers that works flawlessly and even switches the A/B input for me that a lot of guides were warning me about. But NOTHING on the controller. I’m at wits end here.

    Any suggestions?

    EDIT:
    Wow, I feel really dumb. It turned out that I simply forgot some quotes over the device id in the rc.local file. Problem solved.

Viewing 1 post (of 1 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.