Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • sirgouki
    Post count: 2

    I have been trying to set this up for a couple days now, and I was hoping this would just take a couple hours tops. Unfortunately, I was surprised to see that there is a couple of issues regarding autodetection of controllers that makes, at least on my end, a simple plug and play solution impossible.

    First, for some reason, the auto-detection settings for Wireless 360 controllers set buttons to do things like exit the game/emulator, and when pressed trying to setup up the controls in the game, closes out the emulator and I have to start over.

    Next, when I finally got through setting up input but turning off autodetect, I saved a new config file using the on screen options, and it saves as fceumm-retroarch.cfg or something like that. But the emulator is still defaulting to the default settings in all/retroarch.cfg

    Then I found out where the autodetect files are saved, and edited the buttons that are conflicting out, (I am fine with using a keyboard to exit the game) I finally noticed what one of the actual problems are with this whole thing: the NES emulator (the FCEU one) is defaulting to using Xbox 360 Wireless reciever for inputs 1-3 and Xbox 360 controller (userspace configuration) for input 4. When I try to set up the input myself (i.e. changing any button), it switches input 1 to the correct setting.

    Is there any way to correct this so that inputs 1-2 are using the userspace configuration while the 3-4 inputs default to off? I have checked the all/retroarch.cfg, the nes/retroarch.cfg , and some of the settings in emulators/*/ where * = RetroArch and nes

    Note: Obviously, I’m abbreviating the directories, and some stuff may not be worded identical (the userspace configuration for Wireless 360 controllers actual name escapes me right now), currently I’m trying another reinstall of retropie.

    Also, through SSH and directly on the pie, the retroarch-joypad tool does nothing at B button (down) and I have to Escape cancel out of it.

    Post count: 1629

    I may be simplifying, but maybe start your clean install with this approach to your wireless controller and see if that works fine as is. I have mine set to use 1 wireless and, as per the video, I write a new auto file for it.

    Post count: 2

    Windows fudged up my process there, so I had to switch to the Tech Preview of 10 because Win8 wouldn’t even see my sd card. I will try once I get it set up again.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.