Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • Anonymous
    Inactive
    Post count: 5

    I recently got RetroPie set up to run Super Smash Bros. and Majora’s Mask, and they both seem very slow and glitchy. I am using the standard n64 folder, not the other one.

    Super Smash Bros.: I get on to see the logos just fine, and Master Hand appears. He goes into the chest in the intro scene and everything freezes. No big deal, because the game clips back to dragging Link on the desk. But then Link becomes entirely black, so does Master Hand. After that, he does his normal countdown, and instead of the character pictures flashing, I see them all at once in a solid state just staring there. Can’t do anything.

    Majora’s Mask: Again, logo runs fine, but no intro happens. No sounds or anything. I hit the start button to hear the sound slow and glitchy, and no Majora’s Mask logo appears. I hit start again, but only to come to a slow and sound glitched file menu, and the background’s sky box’s (as I call it) texture hasn’t loaded correctly.

    If anyone could offer any help or give me a config file to replace the old one to make it less of what it is above, please send me a comment. I would appreciate a quick one if possible, as I need to get off soon.

    -Hudson

    gizmo98
    Participant
    Post count: 452

    Update RetroPie-Setup script and install experimental/mupen64plus-testing. There will be at least two new rom folders /rom/n64-gles2rice and /rom/n64-gles2n64. Use gles2rice for zelda games. Use gles2n64 for mario64, mario kart and super smash brothers.

    Mupen64plus-testing is broken atm but should be fixed soon.

    Anonymous
    Inactive
    Post count: 5

    I apologize, as I am kind of new to the RetroPie. Could you link me to somewhere that teaches me how to do that or just teach me yourself?

    gizmo98
    Participant
    Post count: 452

    Same procedure as every day… ;-)

    -Close emulationstation with F4
    -Type:

    cd RetroPie-Setup
    sudo git pull
    sudo ./retropie_setup.sh

    Select experimental packages
    Select Mupen64plus-testing

    It will not compile atm. Mupen64plus-core is broken but a fix is already on the way.

    Anonymous
    Inactive
    Post count: 5

    Yeah, it just sent me back to the Emulation Station after attempted launch. Also, how do I compile it?

    kmhamel
    Participant
    Post count: 50

    How do you setup emulation station to use mupen64plus-testing once you get it built?

    texasliberal
    Participant
    Post count: 10

    somebody feel free to correct me as I am a complete NOOB to RP, but I think from what I’ve read here that once you install the new emulator from the setup screen, you put your roms in the particular folders that gizmo mentioned above and that will make it run the new emulator instead of the default one.

    gizmo98
    Participant
    Post count: 452

    @texasliberal: Exactly!

    @all: mupen64plus-testing should build again.

    ceuse
    Participant
    Post count: 96

    [quote=90380] @texasliberal: Exactly!

    @all: mupen64plus-testing should build again.
    [/quote]

    Great work as allways :-) is it possible to use savestates now aswell? mine allways crashes when i try to load a state.

    joelones
    Participant
    Post count: 6

    I guess the RPi2 is not supported for the testing branch?

    Makefile:113: Architecture “armv7l” not officially supported.’

    gizmo98
    Participant
    Post count: 452
    kmhamel
    Participant
    Post count: 50

    [quote=90361]somebody feel free to correct me as I am a complete NOOB to RP, but I think from what I’ve read here that once you install the new emulator from the setup screen, you put your roms in the particular folders that gizmo mentioned above and that will make it run the new emulator instead of the default one.[/quote]

    Thanks, I thought as much but wasn’t sure. I’ll give it a try.

    loegare
    Participant
    Post count: 2

    [quote=90295]Same procedure as every day… ;-)

    -Close emulationstation with F4
    -Type:

    cd RetroPie-Setup
    sudo git pull
    sudo ./retropie_setup.sh

    Select experimental packages
    Select Mupen64plus-testing

    It will not compile atm. Mupen64plus-core is broken but a fix is already on the way.
    [/quote]

    so i did that today, and it came through flagged as completed, but when i rebooted the Pi i couldnt find it on the emulation station dashboard. what step did i miss?

    gizmo98
    Participant
    Post count: 452

    Put your rom files in the rom path named above.

    loegare
    Participant
    Post count: 2

    that worked! thanks!

    garfield85
    Participant
    Post count: 2

    Hi,

    First off, thank you!

    second, I’ve installed the experimental Mupen emulator and I notice a
    big difference in performance. But still some games are a bit laggy..
    I’ve tried all 3 settings and noticed big differences in all 3.

    Isn’t there a file that that is optimized with all the N64 games of at least most N64 games on the Raspberry Pi 2?

    Greets,
    Michel

    phoenix
    Participant
    Post count: 35

    Unfortunately, for now, that’s the best you are going to get. Some N64 games just don’t emulate well on the pi. Doesn’t matter which emulator you use, Goldeneye is going to be s-l-o-w and other games Like Yoshi and Smash Bros are going to get slower and slower as the game’s graphics get more complex. c’est la vie. It will take a major improvement in the emulation software, or a new model of pi to improve N64 performance. Your best bet is likely PC emulation for those games.

Viewing 17 posts - 1 through 17 (of 17 total)
  • You must be logged in to reply to this topic.