Viewing 1 post (of 1 total)
  • Author
  • daubsi
    Post count: 5

    I’ve just finished my arcade cabinet using two Sanwa digital joysticks and about 20 arcade buttons. All inputs are wired into an iPac2 interface, which is connected to my RPI2 using USB.

    At first I had the iPac in the default keyboard mode with the MAME layout.
    Upon start emulation station asks me to configure the controls and everthing is setup the way I want it to be.
    Everything seemed to work so far in advmame, snes and so on. However I was not able to use that setup using lr-fba-next which I wanted to use as an alternative for advmame.

    No matter what I tried, I was not able to configure the buttons or joysticks using the RetroArch configuration tool. No movement of the joystick or key press was detected.

    Then I decided to use the ipac Windows config utility to configure each input as a joypad button, having 32 buttons now.

    Again I was able to use emulation station to configure the controls and right from the start everything worked perfectly in Retroarch as well. All the buttons are detected and work as expected. I now also get on screen messages like “Ultimatic ipac… found”.

    However I have no problems using the “gamepad” in advmame. Maybe 4-6 “buttons” (incl. joystick movements) work, for the rest there is no reaction. I tried reconfiguring the inputs using the TAB menu, but also this works not very well (not all buttons are recognized)…

    Whats wrong?
    Some questions:
    * In which mode do you guys use the ipac controller? Keyboard or Joypad?
    * If joypad: how do you configure advmame to use it?
    * If keyboard: how to you configure retroarch to use it?
    * Is there a way to emulate an analog stick using the digital joystick? e.g. for racing games on the N64
    * Is there a way to use the “shift” behavior when using the ipac2 in gamepad mode?


Viewing 1 post (of 1 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.