Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • jovinf88
    Participant
    Post count: 3

    My setup:
    RPi 2
    RetroPie v3.0 beta 4
    Burned Image to SD Card with Mac OSX Terminal
    Expanded Memory and Updated Scripts

    Arcade Buttons were setup for 2 player using digitalLumberjacks tutorial: https://www.raspberrypi.org/forums/viewtopic.php?f=78&t=83317

    Went through the whole setup, tested and it worked with jstest for BOTH controllers. I added the below lines and mapped them to my corresponding buttons 6 (Select) and 7 (Start). In my case, I would like to exit by holding Start and then tapping Select. The originals given in the tutorial didn’t work for me either.

    input_enable_hotkey_btn = “7″
    input_exit_emulator_btn = “6″

    Buttons all work fine (including exit) with EmulationStation, PiFBA and MAME after configuring in the fba2x.cfg and the MAME menu with TAB key.

    Test ROM didn’t load at first so I switched snes9x. Game loaded, but exit function is not working properly in RetroArch. The only way I can get out is by using the ESC key on my keyboard.

    Read countless threads and just plain stuck. The multiple retroarch.cfg can be confusing.

    Floob
    Member
    Post count: 1629

    Can you test this with a MegaDrive rom – or any libretro core really – just not mame or pifba ones that may not be using retroarch,

    Can you post as an attachment
    /opt/retropie/configs/all/retroarch.cfg
    and
    /opt/retropie/configs/{systemname}/retroarch.cfg

    jovinf88
    Participant
    Post count: 3

    Tried rom for NES, MegaDrive, Master System and SNES. Unfortunately, none of them are loading properly and return to the EmulationStation.

    I burned once again another v3beta4 image onto my SD card and set everything up from a fresh start. Next expanded, firmware update, binary install, updating script, mkjoystick, etc. EmulationStation frontend works flawless with controls.

    Cannot boot roms once again. Games will only load if emulator is switched from something NOT named with “lr-“. Not to mention I still haven’t figured the exit hotkey issue from my first post.

    I attached the txt/cfg files for retroarch/all and megadrive.

    Floob
    Member
    Post count: 1629

    Theres quite a lot of edits in your file:
    /opt/retropie/configs/all/retroarch.cfg

    And some corrupted characters at the end as well. I wouldnt edit that file if I were you. Just use the stock one – if you want to tweak controls use the system based retroarch, or the controller auto file.

    Check my vids for an overview on how the configs work.

    Try this instead.
    – Write a clean RetroPie 3 beta 4 image
    (Dont update binaries, script, or anything else)
    – Boot it up and try just one rom and see how it goes.
    To test one rom you dont even need to expand the filesystem.

    jovinf88
    Participant
    Post count: 3

    Thats odd because the only part edited was the addition of the controls and hot keys function? The uploaded /opt/retropie/configs/all/retroarch.cfg came in the newly installed copy of v3.0beta4.

    I ended up reverting back to the Rpi2 2.6 image and following the tutorials. Everything is up and running great! I just have to fix the video aspect ratio.

    Do you recommended trying again to work with the 3.0beta4 image?

    Floob
    Member
    Post count: 1629

    Maybe you pasted in the lines

    input_enable_hotkey_btn = “7”
    input_exit_emulator_btn = “6”

    if you fixed those and added
    input_enable_hotkey = alt

    it should work – but I dont know why your controls are set in there, these should be done in the auto config files, with overrides in the system version.
    A dull explanation of that is here:

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.