Homepage Forums RetroPie Project Controller Configuration in RetroPie GnGeo Xbox 360 Wireless Controller

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #101619

    Hi all,

    I’ve read quite a few posts on GnGeo config and watched floob’s video but no matter what I do, my Xbox 360 controller just will not work.

    I’m using an ‘eBay special’ wireless receiver, which works perfectly fine up until now. The only thing that I can see that seems to be odd about it, is that when I look in /dev/input I see js4 and js5. Either way, it should be fine.

    So my gngeorc conf file, for example the coin button, should be COIN=J4B8 which according to jtest is my select button. But this just will not work. I know the config file is being read as I’ve enabled showfps and some effect successfully.

    Can anyone shed any light on this? Thanks


    I’ll be following this thread since I’ve got the same dilemma.



    Try J0B8 for the hell of it.

    Post up your gngeorc if not.


    Well J0 Did the trick!

    I was certain I tried that already. But Oh well :)


    Well…. It sorted did the trick. I can get the analogue axis working, but not the D-Pad which is axis 4 & 5 according to jstest. Analogue Axis 0-3 will all work as left\right & up\down just not 4-5


    Could you post up your gngeorc and jstest results?


    Here is my config using the left thumbstick
    p1control A=J0B0,B=J0B1,C=J0B2,D=J0B3,START=J0B9,COIN=J0B8,UP=J0a1,DOWN=J0a1,LEFT=J0A0,RIGHT=J0A0,MENU=J0B10
    #p2control A=K108,B=K59,C=K111,D=K112,START=K50,COIN=K52,UP=K264,DOWN=K261,LEFT=K260,RIGHT=K262,MENU=K27
    conuntry usa
    system arcade

    jstest: jstest –event /dev/input/js4

    Event: type 2, time 29210, number 5, value -32767
    Event: type 2, time 29320, number 5, value 0
    Event: type 2, time 33080, number 5, value 32767
    Event: type 2, time 33200, number 5, value 0
    Event: type 2, time 33910, number 4, value -32767
    Event: type 2, time 34000, number 4, value 0
    Event: type 2, time 34690, number 4, value 32767
    Event: type 2, time 34790, number 4, value 0


    So when you try J0a1, J0a2, J0a3 its all fine, but J0a4 doesnt do anything?


    Correct, but I have a0, a1 (left thumb) a2, a3 (right thumb) a4, a5 should be the dpad or hat. I Did try setting the hat as per this config: https://github.com/ssilverm/PiMAME/blob/master/.gngeo/gngeorc

    Still no dice.

    I think I might just get rid or GnGeo and use lib-fba

Viewing 9 posts - 1 through 9 (of 9 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.