Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • pliskin
    Participant
    Post count: 1

    Hello, Has anyone tried using this controller with retropie 2.5? http://www.amazon.com/Hyperkin-Inc-Genesis-GN6-USB-Controller/dp/B00KX75UT6/ref=sr_1_2?ie=UTF8&qid=1424876439&sr=8-2&keywords=gn6

    I am running a Pi2 on version 2.5 trying to get this controller to work on megadrive emulator. It seems no matter what I change in the retroarch.cfg file. The button assignments do not change. the directional pad started to work after I ran the update that says it takes 16 hours to complete. Before the only left to right would work. I suspect the emulator is pulling the controller config from somewhere else. as I have copied moved/changed the retroarch file several times. Using the configurator and manually switching assignments. I hope I am missing a step somewhere and if someone would be so kind to help me out here. I’ve hit a wall with next steps to troubleshoot.

    Thanks

    neighbourhoodnerd
    Participant
    Post count: 111

    A few tips from my own experience:
    – /all/retroarch.cfg is the default control scheme (and settings) for all retroarch emulators
    – /genesis/retroarch.cfg is the control scheme and settings file for JUST the genesis emulator, and any settings within it override settings in the /all/ file.
    – If you’re using an old “Skeleton” retroarch.cfg file, note that a lot of the button names have changed.

    I spent ages trying to get this to work, which I had copied from an old thread:

    input_enable_hotkey = "6"
    input_menu_toggle = "3"

    The correct code is actually:

    input_enable_hotkey<strong>_btn</strong> = "6"
    input_menu_toggle<strong>_btn </strong>= "3"

    That one drove me crazy X-D

    neighbourhoodnerd
    Participant
    Post count: 111

    One last thing:
    Make sure joypad_index has the correct number.

    input_player1_joypad_index = "0"

    If you have other devices plugged in, the index number for your controller may be different to what you’re using.

    allroy1975
    Participant
    Post count: 16

    When did it change to /genesis/?

    I’m trying megadrive/retroarch.cfg because that’s what exists..

    I’m on a pi2 running 2.6 and that stuff… I’ve never seen that in any flavor… Including this one.

    I’m having the exact same issue as OP with the same controller.

    Pliskin, did you ever figure it out? I did once before in 2.3 and now I can’t find my old config files and it’s driving me nuts!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.