Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • mallipa
    Participant
    Post count: 2

    I am kinda new so please bear with me.
    when running the n64 emulator I am only able to run the rice and gles. When I try to run the GLiden64 it goes black then returns to emulation station. I am pretty good with command line so I can provide whatever if it helps. I checked my runcommand.log and I am getting a Segmentation Fault? Any help is appreciated.

    /opt/retropie/emulators/mupen64plus/bin/mupen64plus.sh: line 215: 1912 Segmentation fault "$rootdir/emulators/mupen64plus/bin/mupen64plus" --noosd --fullscreen --gfx ${VIDEO_PLUGIN}.so --configdir "$configdir/n64" --datadir "$configdir/n64" "$ROM"

    Also I ran sudo ./retropie_package.sh mupen64plus to get to this point. It worked on my pi2 but I have upgraded to a pi3 and downloaded from binary retropie 3.6

    fistwielder
    Participant
    Post count: 38

    I’m having the same issue. I haven’t found a solution.

    dankcushions
    Participant
    Post count: 432

    Same here. I reinstalled from source and had this problem. I did previously work before I reinstalled from source, so I thought it should work if I reinstalled from binary, but it sounds like you have and it doesn’t…

    i will try and debug the issue soon, unless anyone has any other clues…

    dankcushions
    Participant
    Post count: 432

    I found the issue and a (temporary) solution. See: https://github.com/RetroPie/RetroPie-Setup/issues/1403

    Hopefully a proper fix can be figured out at some point.

    mallipa
    Participant
    Post count: 2

    I was able to run it using the commands you posted in github and didn’t get any errors (game worked fine with GLiden64). I did chmod 777 the mupen64plus directory. However when I run it from emulation station it still doesn’t work. All the other plugins work fine. do you think it could be other settings that caused the problem?

    Reading symbols from /opt/retropie/emulators/mupen64plus/bin/mupen64plus...(no debugging symbols found)...done.
    (gdb) tty /dev/tty1
    (gdb) run
    Starting program: /opt/retropie/emulators/mupen64plus/bin/mupen64plus --noosd --fullscreen --gfx mupen64plus-video-GLideN64.so --configdir /opt/retropie/configs/n64 --datadir /opt/retropie/configs/n64 /home/pi/RetroPie/roms/n64/Mario\ Kart\ 64\ \(U\)\ \[\!\].z64
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/lib/arm-linux-gnueabihf/libthread_db.so.1".
    [New Thread 0x72699460 (LWP 1113)]
    [New Thread 0x70697460 (LWP 1114)]
    [New Thread 0x6fe97460 (LWP 1115)]
    [New Thread 0x6f697460 (LWP 1116)]
    [New Thread 0x6ee97460 (LWP 1117)]
    [New Thread 0x6e697460 (LWP 1119)]
    [New Thread 0x6de97460 (LWP 1120)]
    [Thread 0x6de97460 (LWP 1120) exited]
    [New Thread 0x6de97460 (LWP 1121)]
    [Thread 0x6de97460 (LWP 1121) exited]
    [Thread 0x6e697460 (LWP 1119) exited]
    [Thread 0x72699460 (LWP 1113) exited]
    [Thread 0x6ee97460 (LWP 1117) exited]
    [Thread 0x6f697460 (LWP 1116) exited]
    [Thread 0x6fe97460 (LWP 1115) exited]
    [Thread 0x70697460 (LWP 1114) exited]
    [Inferior 1 (process 1110) exited normally]
    fistwielder
    Participant
    Post count: 38

    It is fixed upstream. You just need to update Mupen64plus now and it will work:

    1. Press F4 to get to console

    2. Type cd RetroPie-Setup then press enter

    3. Type git pull then press enter

    4. Type sudo ./retropie_packages.sh mupen64plus then press enter

    5. Then type emulationstation and press enter to get back into EmulationStation

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.