Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • sinfulangle
    Participant
    Post count: 13

    How would I go about with getting WiFi working with the RetroPie?

    I currently have the ‘Edimax EW-7811UN 150Mbps Wireless Nano USB Adapter’ and the ‘lusb’ command tells me that the Pi detects the USB.

    I have done a bit of googling and research but no tutorials or assistance results with getting WiFI working with the Pi & RetroPie installed.

    Thanks guys.

    RazorX2014
    Participant
    Post count: 41

    load up wpa_gui from the start menu click scan then double click your network then in the “PSK” field, enter your wireless password and click add

    sinfulangle
    Participant
    Post count: 13

    [quote=6288]load up wpa_gui from the start menu[/quote]

    How would I do so?

    And is that the RetroPie Start Menu?

    Edit:I do not have any OS on the Pi, just RetroPie.

    RazorX2014
    Participant
    Post count: 41

    i edited my comment but you need to get to the desktop by hitting f4 from retropie then typing in startx

    sinfulangle
    Participant
    Post count: 13

    [quote=6291]i edited my comment but you need to get to the desktop by hitting f4 from retropie then typing in startx[/quote]

    Awesome, thank you for your help! Currently doing that now.. then WiFi should work with RetroPie?

    RazorX2014
    Participant
    Post count: 41

    yup

    once its all working set this post to resolved :)

    sinfulangle
    Participant
    Post count: 13

    [quote=6294]yup

    once its all working set this post to resolved :)
    [/quote]

    Maybe I didn’t explain myself properly but the problem I’m having is I cannot get an IP from RetroPie. When I enter ‘ifconfig’ it gives an IP of ‘10.0.0.4’ instead of something like ‘192.168.x.x’.

    I did get the internet working instead Raspbian but I want to get the USB WiFi dongle working with RetroPie.

    Thanks. :)

    RazorX2014
    Participant
    Post count: 41

    if you enter startx and setup the wifi and get it working when you logout and go back to retropie it will still be connected to the wifi retropie is basically just a script running on raspbian

    sinfulangle
    Participant
    Post count: 13

    [quote=6296]if you enter startx and setup the wifi and get it working when you logout and go back to retropie it will still be connected to the wifi retropie is basically just a script running on raspbian[/quote]

    Hmm, yes I did all that but when I’m back to RetroPie the IP address is giving me still an internal IP.

    What I am trying to do is connect to the Pi using Cyberduck to drag & drop ROMS into the Pi.

    Maybe I am doing something wrong :\

    RazorX2014
    Participant
    Post count: 41

    i can do that on mine it should work on yours try loading up RetroPie_Setup.sh and setting up samba i think it is that might sort it for you all i can say is it works on mine

    sinfulangle
    Participant
    Post count: 13

    [quote=6298]i can do that on mine it should work on yours try loading up RetroPie_Setup.sh and setting up samba i think it is that might sort it for you all i can say is it works on mine[/quote]

    Got it working, I just pressed network on my PC and my Pi was detected and I’m now dragging & dropping ROMS on, thank you for all your help! :)

    RazorX2014
    Participant
    Post count: 41

    np glad i could help remember to set the post to resolved ;)

    karloss
    Participant
    Post count: 177

    the process is exactly the same as raspbian…

    Step 1.
    Boot the Raspberry Pi without the WiFi adapter plugged in.

    Step 2.
    Open a Terminal session by clicking on the LXTerminal icon, and enter the
    following command into it:

    sudo nano /etc/network/interfaces
    

    Then Edit the file to look like this –

    auto lo
     
    iface lo inet loopback
    iface eth0 inet dhcp
     
    allow-hotplug wlan0
    auto wlan0
     
     iface wlan0 inet dhcp
            wpa-ssid "ssid"
            wpa-psk "password"

    Step 4.
    When you have finished press [ctrl]x. This will ask if you want to save the modified files.
    Press ‘Y’ and then Return to save the file with the same name.

    Step 5.
    Shut down your Raspberry Pi, plug the WiFi adapter in and start it up again. You should find that the Raspberry Pi connects using the WiFi adapter as it boots up.

    job done :)

    sinfulangle
    Participant
    Post count: 13

    [quote=6436]the process is exactly the same as raspbian…

    Step 1.<br>
    Boot the Raspberry Pi without the WiFi adapter plugged in.

    Step 2.<br>
    Open a Terminal session by clicking on the LXTerminal icon, and enter the<br>
    following command into it:

    sudo nano /etc/network/interfaces
    

    Then Edit the file to look like this –

    auto lo
     
    iface lo inet loopback
    iface eth0 inet dhcp
     
    allow-hotplug wlan0
    auto wlan0
     
     iface wlan0 inet dhcp
            wpa-ssid "ssid"
            wpa-psk "password"

    Step 4.<br>
    When you have finished press [ctrl]x. This will ask if you want to save the modified files.<br>
    Press ‘Y’ and then Return to save the file with the same name.

    Step 5.<br>
    Shut down your Raspberry Pi, plug the WiFi adapter in and start it up again. You should find that the Raspberry Pi connects using the WiFi adapter as it boots up.

    job done :)
    [/quote]

    Thank you for your help, although I got it working last week with RazorX2014’s assistance! Thanks anyway :)

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.