Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • somebody
    Participant
    Post count: 8

    Hello, I have been dabbling in RetroPie for a little while now, (At least a month?) and have recently taken on a project of gutting and “RetroPieifying?” a Nintendo Gamecube. I’ve installed the latest update of RetroPie, along with the Gamecon drivers (As well as the sibling one, forget what it’s called) through the RetroPie-Setup script. I am using a RPi 2, with the controller’s ports connected as follows(View the image that should be attached, if not, http://www.int03.co.uk/crema/hardware/gamecube/images/gc-socket1.gif):

    2 – GPIO 2
    3, 4, 7 – GROUND
    6 – 3.3v
    (No mysterious pin 5)

    I then use this command:
    sudo modprobe gamecon_gpio_rpi map=0,0,0,0,3,0
    Also, I tried adding it to /etc/modules, and am VERY unsure about how, and am pretty sure I did it wrong.

    Finally, onto the problems!
    I power on. Nothing acknowledges the controller. I use the modprobe, and still no acknowledgement. I navigate to the correct folder, then use jstest. Also unsure of this command. (jstest /dev/input/js1) Play with the controller, nothing happens.

    Currently using this site for reference: http://www.davesblog.com/blog/2013/12/27/hacking-the-gamecube-controller-on-the-raspberry-pi/

    I’m sorry if I’m missing info or have too much, this is my first post on ANY forum.

    somebody
    Participant
    Post count: 8

    Also, I forgot to add that I am plugging the controller into the port, which is connected to the Pi.

    somebody
    Participant
    Post count: 8

    I’ve been looking at it for a little while, I read the readme. Anyone else think that I am using the modprobe line wrong? I have a hunch that the map may be wrong. BTW, I’ve currently changed the data to gpio4. Used map=0,0,3,0.

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.