Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • Anonymous
    Inactive
    Post count: 2

    Evening all,

    Currently running Retropie 2.6 on PI 2, mainly for SNES games using an iBuffalo Classic USB Gamepad.

    Few niggles here and there but after updating some configs etc all going swimmingly.

    However, is there any way to run the controller configs for specific games/roms? The only game I currently have control issues with is Super Mario All Stars, it works fine right up until you start to play and then nothing……

    I have a feeling I know the answer, but I thought I would ask anyway!

    Cheers

    dankcushions
    Participant
    Post count: 432

    there is, but there’s currently a bug with it: https://github.com/RetroPie/RetroPie-Setup/issues/899

    that said, i have the same controller and mario all stars works fine for me in snes9x (which I think is the default?). perhaps you’ve accidentally created a rom-specific config for this, which it’s using instead of the proper one, causing neither to be read, or some other weird issue? if you look in your roms directory, is there a .cfg file with the same name as the rom?

    Anonymous
    Inactive
    Post count: 2

    Cheers for the reply.

    I checked for specific cfg files last night but could find nothing. It’s bizarre, controller works perfectly otherwise. I did have an issue originally where by button presses were not fully registering (ie half jumps etc) but updating my setup scripts and installing the retroarch configs did the trick there.

    same
    Participant
    Post count: 9

    Hi,

    I am trying to get a rom specific input config for lr-fba without success.

    I edited the ~/Retropie/roms/fba/avsp.zip.cfg with my fixes but it does not seem to be loaded.

    If I edit /opt/retropie/configs/fba/retroarch.cfg, my fixes are loaded but are applied for every game…

    Did someone manage to get it working ?

    Thank you !

    same
    Participant
    Post count: 9

    I saw the bug report mentioned in this thread : https://github.com/RetroPie/RetroPie-Setup/issues/899

    I updated the retropie-setup but I cannot find the command to perform the “runcommand install” as described by joolswills, any help ?

    Thanks !

    same
    Participant
    Post count: 9

    Well I got it working following these steps, after updating retropie-setup script I relaunched it, then selected “Setup / configuration”

    I went through option ‘configure the runcommand’,then selected the ‘default’ option and that was it.

    You may have to reboot your pi (I did).

    Hope it will help some people !

    same
    Participant
    Post count: 9

    The game specific config not loading issue should now be fixed in the v3 RC 1.

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.